Agreement creation does not allow instance edition
search cancel

Agreement creation does not allow instance edition

book

Article ID: 426044

calendar_today

Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

The creator of an agreement instance is not able to edit the same. It needs explicit edit rights

STEPS TO REPRODUCE

  1. Create a user and grant the following access rights
    • Agreement - Navigate
    • Agreement - View - All
    • Agreement - Create
    • Agreement - Create from Template
  2. Login as the user above
  3. Go to Agreements
  4. Create an Agreement by the grid view (+ icon) or New from Template button
  5. Agreement is successfully created
  6. Try to edit the Name field on the grid view

Expected Results: Name to be changed.
Actual Results: You get an error: API-1007 : You are not authorized to process request. Contact your system administrator for necessary security rights.

Environment

Clarity 16.3.3, 16.4.0

Cause

This is caused by DE181463

Resolution

This is currently being investigated

Workaround: Grant Agreements Edit rights to the user

Additional Information

As the Agreement creator you should have edit rights over the instance you created.
On the Details flyout and the Properties module fields are read only.
There is no automatic right granted for agreements