infraprofile-access.*.log files are not rotated in vCenter Server 7.0
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infraprofile-access.*.log files are not rotated in vCenter Server 7.0

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Article ID: 425842

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

In vCenter Server 7.0, log files named infraprofile-access.*.log in the /storage/log/vmware/infraprofile directory are not being rotated correctly.

Over time, these log files accumulate and may lead to disk space exhaustion in the /storage/log partition.

Environment

vCenter Server 7.0

Cause

This issue is caused by a known logging configuration defect in certain versions of vCenter Server 7.0.

Resolution

There is no resolution for this issue within the vCenter Server 7.0.

Additional Information

To mitigate the disk space issue, you can safely delete older log files using the command line.
The following procedure describes how to remove logs older than 14 days.

  1. Log in to the vCenter Server via SSH as root.
  2. Run the following command to delete log files older than 14 days:
    # find /storage/log/vmware/infraprofile -mtime +14 -type f -name infraprofile-access-.*.log -delete