VMware SSO authentication fails in VCF Operations with "Authentication was unsuccessful. Verify your credentials or contact your administrator if the issue persists"
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VMware SSO authentication fails in VCF Operations with "Authentication was unsuccessful. Verify your credentials or contact your administrator if the issue persists"

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Article ID: 425773

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Updated On:

Products

VCF Operations

Issue/Introduction

When attempting to log in to VCF Operations using VMware SSO, the login fails with the error: "Authentication was unsuccessful. Verify your credentials or contact your administrator if the issue persists."

Symptoms include:

  • Users cannot log in via the VMware SSO option.

  • The /storage/vcops/log/analytics-uuid.log contains: Invalid login - message: Cannot complete login due to an incorrect user name or password.

Environment

VCF Operations 9.x

Cause

This issue occurs due to an incorrect Domain Controller FQDN, Bind User Name or Base DN provided during the SSO configuration, preventing VCF Operations from successfully communicating with the Identity Provider.

Resolution

To resolve this issue, you must Edit the SSO configuration with the correct parameters:

  1. Log in to the VCF Operations UI.

  2. Navigate to Fleet Management > Identity & Access > VCF Instances.

  3. Select and Edit the current SSO configuration.

  4. Ensure the Domain Controller FQDN, Bind User Name and Base DN strictly match your AD SSO environment.

  5. Go to Fleet Management > Identity & Access > VCF Management and enable SSO for the required instance.

  6. Ensure that the User Accounts are imported in Administration > Control Panel > Access Control.

  7. Test the login using the VMware SSO option.

Additional Information

VCF SSO Login Failure on vCenter UI 9.0 with Embedded vIDM