vSphere Client service has stopped working with vCenter "503-Service Unavailable" Error due to ESXi CPU Exhaustion - Host CPU at 100% .
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vSphere Client service has stopped working with vCenter "503-Service Unavailable" Error due to ESXi CPU Exhaustion - Host CPU at 100% .

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Article ID: 425633

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

You will notice below errors in the vCenter UI. 

You have no privileges to view this object or it is deleted.

You can use "Search Bar" to find the object you have access to.
No privileges to view this object or it is deleted image.

ex.

After restarting the vCenter Page you will notice the below banner with error "vSphere Client service has stopped working". 

VMware vSphere Client

i vSphere Client service has stopped working.
For troubleshooting refer Skyline Health Diagnostics.

Learn more by checking VMware vSphere Documentation and Support.

For appliance administration, navigate to vCenter Server Management appliance

ex.

After clicking vCenter Server Management appliance link you will notice 503 error

Few of the vCenter Services would be in stopped state. 

Example :

Stopped:
 vmcam vmonapi vmware-content-library vmware-hvc vmware-imagebuilder vmware-netdumper vmware-perfcharts vmware-rbd-watc
hdog vmware-sps vmware-trustmanagement vmware-vapi-endpoint vmware-vcha vmware-vsan-health vsphere-ui

 

When vCenter services are restarted it takes a long time to start and then fails to start few services. 

Environment

vCenter 8.x 

vCenter 9.x

ESXi 8.x 

ESXi 9.x

Cause

The ESXi host CPU reached 100%, this was likely the trigger. High CPU contention often causes vCenter services to time out during their keep-alive checks, leading the watchdog (vmon) to stop them.

The list of services you provided (e.g., vsphere-ui, vmware-sps, vmware-vapi-endpoint) confirms that the core management layers of your vCenter are currently down. When these specific services are "Stopped," the vSphere Client will not load, and the VAMI (port 5480) will return a 503 error because the management API endpoint is not responding.

Resolution

1. Identify the CPU Consumer

Since the CPU of the ESXi host is at 100%, you need to determine the host resources and free up some CPU.

  • Log into the ESXi Host directly (via the Host Client UI).

  • Check Resource Monitor: Look for which VM has the highest CPU usage.

  • Power off or migrate that VM to give vCenter "breathing room."

2. Restart VCSA Services

Once you have freed up some CPU overhead on the host, you need to manually check the status of the vCenter services.

  • Run the following command to see which services are down: service-control --status --all
  • Restart all services: service-control --stop --all && service-control --start --all

Additional Information

ESXi hosts showing high CPU Utilization