Unable to login to Aria Operations for Logs UI page
search cancel

Unable to login to Aria Operations for Logs UI page

book

Article ID: 425238

calendar_today

Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

  • When attempting to login to Aria Operations for Logs the icon keeps spinning indefinitely without loading the page.
  • Reboot of Aria Operations for Logs nodes restores access for the time being but the issue would reoccur after a period of time.
  • The cassandra service appears to be running checking with command on Aria Operations for Logs nodes:

    nodetool-no-pass status

  • High volume of cached tomcat sessions is observed with below command:

    /usr/lib/loginsight/application/lib/apache-cassandra-*/bin/cqlsh-no-pass
    SELECT COUNT(*) FROM logdb.tomcat_sessions;

Environment

Aria Operations for Logs 8.18.X

Cause

The browser session timeout value is set to -1 which means all tomcat sessions would never expire after establishment. This would cause tomcat sessions to accumulate and eventually lead to slow down of applications and UI becoming unresponsive.

Resolution

In situation as such, it's suggested to:

  1. Truncate the tomcat sessions table following Aria Operations for Logs UI is not loading.
  2. Set reasonable time in minutes for the session timeout value. The default is 30 minutes. 
    The setting can be changed in Aria Operations for Logs UI on "General Configuration" page under "BROWSER SESSION".