Unable to login to VCF Operations for Logs 9.0.X with SSO
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Unable to login to VCF Operations for Logs 9.0.X with SSO

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Article ID: 424474

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Updated On:

Products

VCF Operations

Issue/Introduction

  • The Single Sign-On (SSO) configuration appears as "Disabled" within the VMware Aria Operations for Logs interface.

  • Attempting to log in with VCF SSO results in the error "Failed to establish a connection with VCF SSO server."

  • The Overview menu displays the following error message: "Failed to download fields. The list of fields is incomplete."

  • The VMware Aria Operations for Logs ui_runtime.log reports a failure to initialize the SSL socket factory due to trust store issues.

  • The log file: /storage/core/loginsight/var/ui_runtime.log contains entries similar to the following:

    [2026-01-07 10:11:10.511+0000] ["https-openssl-apr-443-exec-1"/#.#.#.# ERROR] [com.vmware.loginsight.web.actions.APIProxyActionBean] [Error creating SSL socket factory.]
    		java.security.KeyStoreException: Failed to load default trust store.

Environment

VCF Operations for Logs 9.0.x

Cause

The truststore on the VCF Operations for Logs node is corrupted.

Resolution

  1. Take snapshots without memory for all VCF Operations for Logs nodes. How to take a Snapshot of VMware Aria Operations for Logs

  2. Perform the truststore replacement by following the steps outlined in the VMware KB article  How to replace a corrupted truststore in Aria Operations for Logs