vSphere Client で "no healthy upstream" が表示され vCenter Server へログインができない
search cancel

vSphere Client で "no healthy upstream" が表示され vCenter Server へログインができない

book

Article ID: 422674

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

免責事項: これは英文の記事「"no healthy upstream" error when attempting to access the vCenter Server vSphere Client」の日本語訳です。記事はベストエフォートで翻訳を進めているため、ローカライズ化コンテンツは最新情報ではない可能性があります。最新情報は英語版の記事で参照してください。

  • vCenter が停止している。
  • vSphere Client で vCenter Server へのログインができない。
  • ウェブブラウザで vCenter Server の FQDN を入力すると以下のエラーが表示される。

    no healthy upstream

 

  • LAUNCH VSPHERE CLIENT のクリック後に "no healthy upstream" エラーが表示される場合がある。

 

  • エラーメッセージは、"websso" ページにリダイレクト中に表示される場合がある。

Environment

VMware vCenter server 8.x

Cause

本問題の原因として、以下のような要因が考えられます。

  • vCenter Server の VPXD サービスが起動していない、または接続できない状態:
    • 証明書の失効
    • ディスク使用量の逼迫.
    • セッション数の上限超過(最大 2,000 セッション)
    • サービスのメモリ不足
    • 計画的メインテナンス、またはアップデートの実施中
  • SSO サービス (vmware-stsd) が停止している、または応答しない状態
    • サービスのメモリ不足
    • 計画的メインテナンス、またはその他の要因
  • /etc/hosts ファイルがデフォルト設定から変更されたことによるサービス起動失敗
  • LDAP クライアントでエラーを受信したことによる lookupsvc の起動失敗

Resolution

トラブルシューティングを開始する前に「no healthy upstream」エラーが何を意味するのかを理解することが重要です。「no_healthy_upstream」は HTTP サーバ エラー レスポンス ステータスコード 503 と同類のメッセージであり、サーバーが一時的にリクエストを処理する準備ができていないことを示します。

 

「no healthy upstream」エラーが証明書の期限切れによって発生しているかどうかを確認するには、以下の KB 記事に記載されている手順を使用して、vCenter Server 上の証明書の有効期限をご確認ください。

vCenter Server 上の自己署名証明書を更新/再生成するには、以下の KB 記事に記載されている手順に従い、vCenter Server の Certificate Manager ユーティリティをご使用ください。

以下の KB 記事で言及されている LDAP の問題を確認するには、 

 

Additional Information

vCenter Server のサービス ステータスを確認するには、