"no healthy upstream" error when attempting to access the vCenter Server vSphere Client
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"no healthy upstream" error when attempting to access the vCenter Server vSphere Client

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Article ID: 390105

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

  • Logging in to the vCenter Server using the vSphere Client fails.
  • The following error is observed when trying to access the vCenter Server via FQDN from a web browser:

    no healthy upstream

 

  • In certain situations, you will get the "no healthy upstream" error immediately after clicking on "Launch vSphere Client":

 

  • The error message is observed while redirecting to "websso" page:

Cause

This issue may occur due to a number of reasons, such as:

  • The VPXD service on the vCenter Server is not running or not accepting connections due to:
    • Expired certificates
    • Disk space issues.
    • Running out of sessions (reached the maximum limit of 2000)
    • The service running out of memory
    • Scheduled maintenance, such as updates.
  • The SSO service (vmware-stsd) is down or not responding due to:
    • The service running out of memory
    • Scheduled maintenance, etc.
  • The file /etc/hosts has been modified from its default configuration, preventing services from starting.

Resolution

Before troubleshooting, it is critical to understand what a "no healthy upstream" error means. "no_healthy_upstream" is an alternate error message for HTTP Return code 503, which indicates that the server is temporarily unable to handle the request.

 

To verify if a "no healthy upstream" error is being caused by expired certificates, please use the steps in the following KB article to verify the certificate expiration dates on the vCenter Server:

 

To renew/regenerate the self-signed certificates on a vCenter Server, please use the Certificate Manager utility on the vCenter Server using the steps detailed in the following KB article: