One or more NSX Manager appliances intermittently missing from the NSX UI
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One or more NSX Manager appliances intermittently missing from the NSX UI

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Article ID: 422506

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Updated On:

Products

VMware NSX

Issue/Introduction

  • One or more NSX Manager appliances intermittently missing from the NSX UI:
    Under : System > Appliances

    NB:  NSX cluster intermittently displays as "Unavailable" in the NSX UI in a one node cluster. 

  • get cluster status via CLI shows the cluster is stable and healthy.

  • NSX Manager log entries similar to the below are repeatedly observed for API call 'GET /api/v1/ui-controller/cluster-nodes-aggregate-info':
    /var/log/syslog:
    <Timestamp> nsx-manager NSX 5886 SYSTEM [nsx@6876 audit="true" comp="nsx-manager" level="INFO" subcomp="manager"] UserName:'admin' ModuleName:'common-services' Operation:'GET@/api/v1/ui-controller/cluster-nodes-aggregate-info' Operation status: 'failure' Error: General error has occurred.
  • This is a cosmetic issue with no impact on the Data Plane or Management Plane

Environment

VMware NSX

Cause

The NSX UI has a polling logic to update the management cluster status.  This poling logic triggers API call 'GET /api/v1/ui-controller/cluster-nodes-aggregate-info' every 7 seconds.  If there is no API response within this 7 second period, the default cluster status value "Unavailable" is displayed.

Resolution

This is a condition that may occur in a VMware NSX environment.

NB:  API logic has been improved in VMware NSX 9.0 to help prevent this issue from occurring.

This issue is resolved in VMware NSX 9.0, available at Broadcom downloads.

If you are having difficulty finding and downloading software, please review the Download Broadcom products and software KB.