Inaccessible vSAN objects after disk failure on vSAN node with vSAN FS enabled
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Inaccessible vSAN objects after disk failure on vSAN node with vSAN FS enabled

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Article ID: 421834

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Updated On:

Products

VMware vSAN

Issue/Introduction

The vSAN cluster previously experienced disk failure on one or more hosts; following disk replacement, the following symptoms were observed.

Symptoms :

  • vSAN skyline health check - VSAN OBJECT HEALTH reports Inaccessible objects,

  • There are no VMs or any workload impacted.

  • vSAN file service infrastructure health check is healthy

Environment

VMware vSAN 8.x

Cause

  • The inaccessible objects are stale and belong to FSVM(File Server VM) which were residing on the host with a faulty disk.

  • The objects are stale as the components which make up these objects resided on failed disk.

  • Example of an inaccessible FSVM object impacted by this issue:

     Object UUID: ########-####-####-####-############
       Version: 20
       Health: inaccessible - Lost data availability.(APD)
       Owner: 00000000-0000-0000-0000-000000000000
       Size: 0.00 GB
       Used: 0.00 GB
       Used 4K Blocks: 0.00 GB
       Policy:
          stripeWidth: 1
          proportionalCapacity: [0, 100]
          hostFailuresToTolerate: 0
          affinity: ['########-####-####-####-############']
          forceProvisioning: 1
          affinityMandatory: 1
          spbmProfileId: ########-####-####-####-############
          spbmProfileGenerationNumber: 0
          objectVersion: 20
          migrateForDecom: 1
          CSN: 1237
          spbmProfileName: FSVM_Profile_DO_NOT_MODIFY
          locality: HostLocal

       Configuration:

          Component: ########-####-####-####-############
            Component State: ABSENT,  Address Space(B): 8589934592 (8.00GB),  Disk UUID: ########-####-####-####-############,  Disk Name: N/A
            Votes: 1,  Host UUID: None

       Type: N/A
       Path: N/A
       Group UUID: ########-####-####-####-############
       Directory Name: N/A

     

  • It could be seen that :

    • They belong to FSVMs from the "sbpmprofilename".

    • This object belongs to FSVM pinned to host with UUID mentioned in the affinity parameter. To find this host the output of command esxcli vsan cluster get can be validated.

    • The object is inaccessible as the component is absent from "Component State"

    • The inaccessible object is stale as the "Disk Name" and "Host UUID" is empty.

Resolution

If the above symptoms and cause match, kindly open a case with Broadcom Technical Support to assist with clearing up the stale inaccessible vSAN objects.