Scheduled reports are generated but not received by recipients
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Scheduled reports are generated but not received by recipients

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Article ID: 421655

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Updated On:

Products

VMware Aria Operations (formerly vRealize Operations) 8.x

Issue/Introduction

  • Scheduled reports are successfully generated and displayed under "Generated Reports" in Aria Operations but not received by intended recipients.
  • When testing connection to SMTP server from Aria Operations under "Edit Outbound Instance", below error is observed:

    Test was not successful: Email test error: [Could not connect to SMTP host: <SMTP host ip>, port 25, response: 421]

  • Same error code is returned when testing connection to SMTP server with curl command in CLI:

    curl -v telnet://<SMTP host ip>:25
    * Trying <SMTP host ip>:25...
    * Connected to <SMTP host ip> port 25
    421 4.3.2. Service not available

Environment

VMware Aria Operations 8.x

Cause

The SMTP relay server is not accepting connection from Aria Operations because Aria Operations nodes are not whitelisted on SMTP relay server.

Resolution

Whitelist the Aria Operations nodes on the SMTP relay server after which there's no error reported in the output of curl command or test connection to SMTP server. The generated report can be received with no issue. 

Additional Information

Below KB can be of reference as well when troubleshooting issue of scheduled reports not being received:

Scheduled reports are not being received

Aria Operations failing to Send Scheduled Reports via Email