Scheduled reports are not being received
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Scheduled reports are not being received

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Article ID: 395235

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Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

  • Scheduled reports sent via email show Completed under Generated Reports in Aria Operations but are not received by the intended recipient
  • Test emails sent from the Standard Email Plugin under Outbound Settings complete successfully
  • Aria Operations can potentially send an email report from any of the analytics nodes in the cluster, not just the primary node

Environment

VMware Aria Operations 8.18.x

Cause

If you are using email relay servers to send email, each Aria Operations node must have access to relay emails.

Test sending an email from the command line:

  1. Log in to each Aria Operations node with root
  2. Create a small text file in the /root directory: 
    echo "Test mail file" > mail.txt
  3. Using the settings in the Outbound email configuration that is used for the report, run this curl command to test sending an email:
    curl -vvvvv smtp://<FQDN of your mail server> --mail-from <senders email> --mail-rcpt <email recipient> --upload-file ~/mail.txt
  4. Verify that the recipient received the email
  5. If the email was not received, the output for the curl command should include a message similar to: 554 Relay access denied

Resolution

Configure your email relay server to allow all Aria Operations nodes to send email.