Connecting to an Online Depot for VCF Fleet Management fails with error
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Connecting to an Online Depot for VCF Fleet Management fails with error

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Article ID: 420533

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Updated On:

Products

VCF Operations

Issue/Introduction

  • Connecting to an Online Depot for VCF Fleet Management fails with the error "Error in setting Online depot configuration". Use the following documentation as a guide Connect to an Online Depot for VCF Operations fleet management.
  • Errors in /var/log/vrlcm/vmware_vrlcm.log in Fleet Management are similar to :
    INFO vrlcm[###] [http-nio-8080-exec-6] [c.v.v.l.l.s.SettingsServiceImpl]  -- manifest url : https://dl.broadcom.com/<token>//PROD/metadata/manifest/v1/vcfManifest.json
    ERROR vrlcm[####] [http-nio-8080-exec-6] [c.v.v.l.u.DownloadHelper]  -- Download failed.URL : https://dl.broadcom.com/<token>//PROD/metadata/manifest/v1/vcfManifest.json, Connect to dl.broadcom.com:443 [dl.broadcom.com/###.###.###.###, dl.broadcom.com/###.###.###.###, dl.broadcom.com/####:####:####:####:####:####:####:####, dl.broadcom.com/####:####:####:####:####:####:####:####] failed: Network is unreachable (connect failed)
  •  Additional errors in /var/log/vrlcm/vmware_vrlcm.log in Fleet Management are similar to :
    ERROR vrlcm[####] [pool-3-thread-44] [c.v.v.l.p.c.m.t.CloudMarketplaceSyncTask]  -- Sync operation failed: Error while fetching details from cloud Marketplace. Hence failing task. Disconnected Environment or connection issue.
    ERROR vrlcm[####] [pool-3-thread-44] [c.v.v.l.p.c.m.t.CloudMarketplaceSyncTask]  -- Exception occurred :: com.vmware.vrealize.lcm.common.marketplace.exceptions.MarketPlaceException: Error while fetching details from cloud Marketplace. Hence failing task. Disconnected Environment or connection issue.
    INFO vrlcm[####] [pool-3-thread-44] [c.v.v.l.p.a.s.Task]  -- Injecting task failure event. Error Code : 'LCMMARKETPLACE13101', Retry : 'true', Causing Properties : '{ CAUSE ::  }' com.vmware.vrealize.lcm.common.marketplace.exceptions.MarketPlaceException: Error while fetching details from cloud Marketplace. Hence failing task. Disconnected Environment or connection issue.
  • Further errors found in /var/log/vrlcm/vmware_vrlcm.log in Fleet Management are similar to :
    INFO vrlcm[####] [http-nio-8080-exec-9] [c.v.v.l.l.c.CertificateManagementController]  -- Request received to get certificate from https://dl.broadcom.com
    INFO vrlcm[####] [http-nio-8080-exec-9] [c.v.v.l.l.s.CertificateManagementService]  -- Fetching certificate from https://dl.broadcom.com
    INFO vrlcm[####] [http-nio-8080-exec-9] [c.v.v.l.u.CertificateUtil]  -- Endpoint : https://dl.broadcom.com
    ERROR vrlcm[####] [http-nio-8080-exec-9] [c.v.v.l.u.CertificateUtil]  -- IOException occurred - connect timed out
  • The Online Depot Configuration from VCF Operations UI fails with the following error while accepting the certificate:

    Connection failed : Connection reset



  • The Fleet Management log "/var/log/vrlcm/vmware_vrlcm.log", reported Connection reset while trying to communicate to "dl.broadcom.com" over port 443

    -- I/O exception (java.net.SocketException) caught when processing request to {s}->https://dl.broadcom.com:443: Connection reset
    INFO vrlcm[1290] [http-nio-8080-exec-9] [o.a.h.i.e.RetryExec] -- Retrying request to (s)->https://dl.broadcom.com:443
    INFO vrlcm[1290] [http-nio-8080-exec-9] [o.a.h.i.e.RetryExec] -- 1/0 exception (java.net.SocketException) caught when processing request to {s}>https://dl.broadcom.com:443: Connection reset
    
    ERROR vrlcm[1290] [http-nio-8080-exec-9] [c.v.v.l.u.DownloadHelper] - Download failed.URL : https://dl.broadcom.com/wEY3WcghuI8Ebhroz20817sTom97x2xV//PROD/metadata/manifest/u1/ucfManifest.json, Connection reset
    INFO vrlcm[1290] [http-nio-8080-exec-9] [c.v.v.l.l.u.SettingsHelper] - settings data {"userName":"dummy_download_token_user","password": "JXJXJXJX","offlineDepotUrl":null,"directoryPath":null,"isEnabled":false,"depotType":"online","trustCertificate":false}
    
    ERROR vrlcm[1290] [http-nio-8080-exec-2] [c.v.v.l.u.CertificateUtil] - IOException occurred - Connection reset

     

  • The following command from VCF Fleet Management appliance verifies connectivity to dl.broadcom.com over port 443 fails:

    curl -v telnet://dl.broadcom.com:443
    * Host dl.broadcom.com:443 was resolved.
    * IPv6: ####:####:#: :##, ########:##:##
    * IPv4: ##.##.##.##,  ##.##.##.##
    Trying [ ####:####:#: :##]:443.
    * Immediate connect fail for ####:####:# :: ##: Network is unreachable

Environment

VCF Fleet Management 9.0.x

Cause

The connection failed because network-level interruptions or security restrictions (such as a firewall or proxy) blocked the TLS handshake with dl.broadcom.com on port 443.

Resolution

Follow these steps to enable correct certificate validation for VCF Fleet Management and complete the Online Depot Configuration:

  1. Whitelist the Depot FQDN (dl.broadcom.com) on your firewall/gateway to allow VCF Fleet Management to bypass the proxy.
    Unable to Register License in VCF Operations in Connected Mode

  2. Ensure the Security team permits HTTPS egress traffic over port 443 specifically for this endpoint to facilitate certificate validation.

  3. Re-initiate the Online Depot configuration 

Additional Information

Internal error while validating credentials - Can not connect to online depot

Certificate validation fails during Depot setup in VMware Cloud Foundation Fleet Management when using a Proxy