Connect to an Online Depot for VCF Operations fleet management fails with the error "Error in setting Online depot configuration"
search cancel

Connect to an Online Depot for VCF Operations fleet management fails with the error "Error in setting Online depot configuration"

book

Article ID: 420533

calendar_today

Updated On:

Products

VCF Operations

Issue/Introduction

  • Connecting to an Online Depot for VCF Operations Fleet Manager fails with the error "Error in setting Online depot configuration" .  You can use the following documentation as a guide Connect to an Online Depot for VCF Operations fleet management 
  • Errors in /var/log/vrlcm/vmware_vrlcm.log in Fleet Manager are similar to :
    2025-11-19T10:31:41.128Z INFO vrlcm[###] [http-nio-8080-exec-6] [c.v.v.l.l.s.SettingsServiceImpl]  -- manifest url : https://dl.broadcom.com/<token>//PROD/metadata/manifest/v1/vcfManifest.json
    2025-11-19T10:33:41.228Z ERROR vrlcm[####] [http-nio-8080-exec-6] [c.v.v.l.u.DownloadHelper]  -- Download failed.URL : https://dl.broadcom.com/<token>//PROD/metadata/manifest/v1/vcfManifest.json, Connect to dl.broadcom.com:443 [dl.broadcom.com/###.###.###.###, dl.broadcom.com/###.###.###.###, dl.broadcom.com/####:####:####:####:####:####:####:####, dl.broadcom.com/####:####:####:####:####:####:####:####] failed: Network is unreachable (connect failed)

     

  •  Additional errors in /var/log/vrlcm/vmware_vrlcm.log in Fleet Manager are similar to : 
    2025-11-19T10:39:13.105Z ERROR vrlcm[####] [pool-3-thread-44] [c.v.v.l.p.c.m.t.CloudMarketplaceSyncTask]  -- Sync operation failed: Error while fetching details from cloud Marketplace. Hence failing task. Disconnected Environment or connection issue.
    2025-11-19T10:39:13.105Z ERROR vrlcm[####] [pool-3-thread-44] [c.v.v.l.p.c.m.t.CloudMarketplaceSyncTask]  -- Exception occurred :: com.vmware.vrealize.lcm.common.marketplace.exceptions.MarketPlaceException: Error while fetching details from cloud Marketplace. Hence failing task. Disconnected Environment or connection issue.
    2025-11-19T10:39:13.105Z INFO vrlcm[####] [pool-3-thread-44] [c.v.v.l.p.a.s.Task]  -- Injecting task failure event. Error Code : 'LCMMARKETPLACE13101', Retry : 'true', Causing Properties : '{ CAUSE ::  }' com.vmware.vrealize.lcm.common.marketplace.exceptions.MarketPlaceException: Error while fetching details from cloud Marketplace. Hence failing task. Disconnected Environment or connection issue.
  • Further errors found in /var/log/vrlcm/vmware_vrlcm.log in Fleet Manager are similar to : 
    2025-11-19T11:55:14.019Z INFO vrlcm[####] [http-nio-8080-exec-9] [c.v.v.l.l.c.CertificateManagementController]  -- Request received to get certificate from https://dl.broadcom.com
    2025-11-19T11:55:14.019Z INFO vrlcm[####] [http-nio-8080-exec-9] [c.v.v.l.l.s.CertificateManagementService]  -- Fetching certificate from https://dl.broadcom.com
    2025-11-19T11:55:14.019Z INFO vrlcm[####] [http-nio-8080-exec-9] [c.v.v.l.u.CertificateUtil]  -- Endpoint : https://dl.broadcom.com
    2025-11-19T11:55:19.024Z ERROR vrlcm[####] [http-nio-8080-exec-9] [c.v.v.l.u.CertificateUtil]  -- IOException occurred - connect timed out

Environment

VCF Operations Fleet Manager 9.x

Cause

Firewall was blocking traffic for VCF Operations Fleet Manager

Resolution

Ensure your firewall is not blocking traffic for VCF Operations Fleet Manager IP/FQDN and the listed URLS available in the KB