SRM service starts and stop and fails to connect to vCenter
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SRM service starts and stop and fails to connect to vCenter

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Article ID: 420206

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Updated On:

Products

VMware Live Recovery

Issue/Introduction

The SRM appliance running version 9.0 starts and stop and fails to connect to vCenter.

Trying to reconfigure the appliance gives an error, and you see on vmware-dr.log the following message:

2025-11-21T15:37:31.487Z info vmware-dr[00972] [SRM@6876 sub=IO.Http] Set user agent error; state: 1, (null), N7Vmacore3Ssl18SSLVerifyExceptionE(SSL Exception: Verification parameters:

--> PeerThumbprint: XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:EC

--> ExpectedThumbprint: XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:99

--> ExpectedPeerName: vcenter-xxx.xxx.xxx

--> The remote host certificate has these problems:

Environment

SRM 9.0

Cause

vCenter certificate has changed and the reconfigure workflow on SRM 9.0 is not able to update it.

Resolution

Upgrade the SRM appliance to version 9.0.2.2 and reconfigure the appliance.

Additional Information

Site Recovery Manager Appliance Upgrade Best Practices

Reconfigure the VMware Live Site Recovery Appliance