ネットワーク障害により iSCSI ターゲットへの接続が失敗しました
search cancel

ネットワーク障害により iSCSI ターゲットへの接続が失敗しました

book

Article ID: 418934

calendar_today

Updated On:

Products

VMware vSphere ESXi VMware vCenter Server

Issue/Introduction

免責事項:これは英文の記事「Connection to iSCSI target fails due to network failure」の日本語訳です。記事はベストエフォートで翻訳を進めているため、ローカライズ化コンテンツは最新情報ではない可能性があります。最新情報は英語版の記事で参照してください。

症状:

  • 構成された iSCSI ストレージ ターゲット アレイに接続しようとしましたが、iSCSI イニシエーターはターゲットへの接続を確立できません。
  • 次のようなエラー イベントが表示されます。
    Login to iSCSI target iqn.1992-08.com.netapp:sn.#### on vmhba40 failed. The iSCSI initiator could not establish a network connection to the target.
  • /var/log/vobd.log ファイルには、iSCSI ターゲットへの接続を確立できなかったことを示すイベントが表示されます。

    iscsiCorrelator] 535636694us: [vob.iscsi.target.connect.error] vmhba33 @ vmk2 failed to login to iqn.1992-08.com.netapp:sn.#### because of a network connection failure.

    [iscsiCorrelator] 535637125us: [esx.problem.storage.iscsi.target.connect.error] Login to iSCSI target iqn.1992-08.com.netapp:sn.#### on vmhba33 @ vmk2 failed. The iSCSI initiator could not establish a network connection to the target.

  • この ESX ホスト ログ ファイル /var/log/vobd.log には、iSCSI ターゲット検出中の失敗が記録されています。

    In (14) vobd[2097763] :[iscsiCorrelator] 2164914633639us: [esx.problem. storage.iscsi.discovery. connect.error]iSCSI discovery 10.##.##.## on vmhba64 failed. The iSCSI Initiator could not establish a network connection to the discovery address.
  • ホスト > 構成 > ストレージ アダプタで、ストレージ アダプタ上の非活動なパスが確認されました。



  • データストアは「全パス ダウン」(APD) 状態になります。

    In var/run/log/vobd.log - 2025-08-12T20:41:35.974Z: [APDCorrelator] 59896600757809us: [vob. storage. apd. start] Device or filesystem with identifier [naa. ####################] has entered the All Paths Down state.

Environment

VMware vSphere ESXi 7.x
VMware vSphere ESXi 8.x

Cause

この問題は、ストレージ アレイ構成、ホスト ネットワーク構成、または環境全体に設定された MTU サイズを含む VMware ESXi 製品の設定が不適切であるために発生します。

Resolution

接続エラーを解決するには:

  • iSCSI イニシエーターの構成が正しいかどうかを確認します。
  • アレイが動作可能/認定されているかどうかを確認してください。アレイの互換性を確認するには、「VMware 互換性ガイド」を参照してください。
  • ストレージ デバイスにデフォルト ゲートウェイが定義されており、アレイがホストに ping できることを確認します。
  • ホストがアレイに対してpingまたはvmkpingを実行できるかどうかを確認します。

    [root@esxi01:~] vmkping -I vmk# 192.168.#.### -d -s 1472
    PING 192.168.#.### (192.168.#.###): 1472 data bytes

    --- 192.168.#.### ping statistics ---
    3 packets transmitted, 0 packets received, 100% packet loss

  • 使用中のMTU(通常フレーム、ジャンボフレーム)のエンドツーエンド接続を確認してください。詳細は「Troubleshooting ESXi connectivity to iSCSI arrays using software initiators」を参照してください。
  • ポートバインディングが有効になっている場合は、設定が正しいことを確認し、VMkernelポートのバインディングを解除してからバインディングしてみてください。例えば、ストレージアレイのIPアドレスとポートにバインドされているVMkernelのIPアドレスは、どちらも同じサブネット上になければなりません。詳細については、「ESXi でソフトウェア iSCSI ポート バインディングを使用する際の考慮事項」を参照してください。

 

iSCSI 接続の問題のトラブルシューティングの詳細については、「Troubleshooting ESXi connectivity to iSCSI arrays using software initiators」を参照してください。

ストレージおよびネットワーク ベンダーに連絡して、問題をさらに調査してください。