Connection to iSCSI target fails due to network failure
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Connection to iSCSI target fails due to network failure

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Article ID: 334242

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Updated On:

Products

VMware vCenter Server VMware vSphere ESXi

Issue/Introduction

Symptom:

  • While attempting  to connect to a configured iSCSI storage target array, the iSCSI initiator is unable to establish a connection to the target.
  • An error event similar to this is displayed:

Login to iSCSI target iqn.1992-08.com.netapp:sn.#### on vmhba40 failed. The iSCSI initiator could not establish a network connection to the target.

  • In the /var/log/vobd.log file, an event indicating a failure to establish a connection to an iSCSI target is seen:

iscsiCorrelator] 535636694us: [vob.iscsi.target.connect.error] vmhba33 @ vmk2 failed to login to iqn.1992-08.com.netapp:sn.#### because of a network connection failure.

[iscsiCorrelator] 535637125us: [esx.problem.storage.iscsi.target.connect.error] Login to iSCSI target iqn.1992-08.com.netapp:sn.#### on vmhba33 @ vmk2 failed. The iSCSI initiator could not establish a network connection to the target.

  • In this ESX host log file /var/log/vobd.log, a failure during iSCSI target discovery is seen:

In (14) vobd[2097763] :[iscsiCorrelator] 2164914633639us: [esx.problem. storage.iscsi.discovery. connect.error]iSCSI discovery 10.##.##.## on vmhba64 failed. The iSCSI Initiator could not establish a network connection to the discovery address.

 

Environment

VMware vSphere ESXi 6.x

VMware vSphere ESXi 7.x

VMware vSphere ESXi 8.x

Cause

This issue occurs due to improper storage array configuration, host networking configuration, or the VMware ESXi product including the MTU size set across the environment. 

Resolution

To resolve connectivity errors:

  • Verify if the iSCSI initiator configuration is correct.
  • Verify if the array is operational/certified. To verify if the array is compatible, see the VMware Compatibility Guide.
  • Verify and ensure that the storage device has a default gateway defined and the array can ping the host.
  • Check if the host can ping or vmkping the array.

    [root@esxi01:~] vmkping -I vmk# 192.168.#.### -d -s 1472
    PING 192.168.#.### (192.168.#.###): 1472 data bytes

    --- 192.168.#.### ping statistics ---
    3 packets transmitted, 0 packets received, 100% packet loss

  • Verify end-to-end connectivity for MTU in use (regular, Jumbo frames). See Troubleshooting ESXi connectivity to iSCSI arrays using software initiators.
  • If port binding is enabled, verify if the configuration is correct and try unbinding and binding vmkernel port. For example, the IP address of the storage array and port bound vmknic IP address MUST both be on the same subnet. For more information refer, Considerations for using software iSCSI port binding in ESX/ESXi (2038869).
For more information on troubleshooting iSCSI connectivity issues, see Troubleshooting ESXi connectivity to iSCSI arrays using software initiators.