Unable to launch the vSphere Client. No healthy Upstream
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Unable to launch the vSphere Client. No healthy Upstream

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Article ID: 418844

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

Unable to connect to vCenter Server via vSphere UI.  The following error message is received:

no healthy upstream

Environment

  • vCenter Server 8.x

Cause

The vmware-stsd service is not starting.

Results from VDT show that the STS certificate has expired.

Additional causes may include:

  • Disk space issues
  • Running out of sessions (reached the maximum limit of 2000)
  • The service is running out of memory
  • Scheduled maintenance

Reference KB article:

"no healthy upstream" error when attempting to access the vCenter Server vSphere Client

Resolution

  1. Take a snapshot of the vCenter Server VM.
  2. Use the vCert Tool to review and renew the STS certificate.
    1. Download the vCert utility from KB article 385107:
      1. vCert - Scripted vCenter expired certificate replacement
    2. Copy the vCert zip file onto the vCenter using a file transfer utility such as scp or Win SCP.
      1. It is recommended to copy the file into either the /root or /tmp directory.
    3. Navigate into the directory where the zip file was copied to and unzip the vCert utility.
    4. Use "chmod +x vCert.py" to set execute permissions and run the utility "./vCert.py"
    5. Choose option 1 to review all of the certificates and confirm the STS certificate has expired.
    6. Choose option 3, option 8 to review and renew the STS certificate
    7. Restart the VMware vCenter Server services
  3. Confirm all services have started and exit the script
    1. The services can be checked with the following command:
      1. "service-control --status"

Additional Information

Reference KB articles:

vCert - Scripted vCenter expired certificate replacement

Using the VCF Diagnostic Tool for vSphere (VDT)