Enabling VM fault tolerance task fails
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Enabling VM fault tolerance task fails

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Article ID: 418726

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

Fault tolerance configuration of the VMs fail in few mins after the task is submitted. 

 

/var/run/log/hostd.log has the below warnings

YYYY-MM-DDThh:mm:ss.zzzZ Db(167) Hostd[2099791]: [Originator@6876 sub=Vigor.Vmsvc.vm:/vmfs/volumes/<Volume_ID>/<VM_Home_Dir>/<VM_Name>.vmx] VMotionPrepare: MigrateFromDest message: Timed out waiting for migration data.
YYYY-MM-DDThh:mm:ss.zzzZ Db(167) Hostd[2099731]: -->
YYYY-MM-DDThh:mm:ss.zzzZ Db(167) Hostd[2099778]: [Originator@6876 sub=Vmsvc.vm:/vmfs/volumes/<Volume_ID>/<VM_Home_Dir>/<VM_Name>.vmx] VMotionStatusCb [4011234409086565565]: Failed with error [N3Vim5Fault20GenericVmConfigFaultE:0x00000070ccdad3f0]
YYYY-MM-DDThh:mm:ss.zzzZ In(166) Hostd[2099778]: [Originator@6876 sub=Libs] VigorTransportClientManageConnection: connection closed
YYYY-MM-DDThh:mm:ss.zzzZ Db(167) Hostd[2099778]: [Originator@6876 sub=Vmsvc.vm:/vmfs/volumes/<Volume_ID>/<VM_Home_Dir>/<VM_Name>.vmx] VMotionStatusCb: Firing ResolveCb
YYYY-MM-DDThh:mm:ss.zzzZ In(166) Hostd[2099778]: [Originator@6876 sub=Vcsvc.VMotionDst.4011234409086565565] ResolveCb: VMX reports needsUnregister = false for migrateType MIGRATE_TYPE_FTCPT
YYYY-MM-DDThh:mm:ss.zzzZ In(166) Hostd[2099778]: [Originator@6876 sub=Vcsvc.VMotionDst.4011234409086565565] ResolveCb: Failed with fault: (vim.fault.GenericVmConfigFault) {
YYYY-MM-DDThh:mm:ss.zzzZ In(166) Hostd[2099731]: -->    faultMessage = (vmodl.LocalizableMessage) [
YYYY-MM-DDThh:mm:ss.zzzZ In(166) Hostd[2099731]: -->       (vmodl.LocalizableMessage) {
YYYY-MM-DDThh:mm:ss.zzzZ In(166) Hostd[2099731]: -->          key = "msg.checkpoint.migration.noprogress",
YYYY-MM-DDThh:mm:ss.zzzZ In(166) Hostd[2099731]: -->          message = "Timed out waiting for migration data.

Cause

Inconsistent MTU setting or network connectivity issue is causing the FT task to fail due to communication errors.

MTU inconsistencies can be determined by following the KB Testing jumbo frame pings from ESXi over the network

Resolution

Resolve the network connectivity issues / MTU inconsistencies between the hosts. If the MTU of the VMK interface is set to use jumbo frames, make sure the virtual switches and physical network infra is configured to support it.

Additional Information

Enabling Jumbo Frames on virtual switches

Troubleshooting network and TCP/UDP port connectivity issues on Hosts