Unable to ping the ESXi host. Ping to the host is lost intermittently.
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Unable to ping the ESXi host. Ping to the host is lost intermittently.

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Article ID: 418550

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

  • Ping to the ESXi host is lost intermittently.
  • Host has been re-installated by end user while performing firmware upgrade.
  • Prior making changes, management kernel of the ESXi host was in DVS. 
  • Route Based on Originating Virtual Port is the default load balancing method on the vSphere Standard Switch and vSphere Distributed Switch.

Environment

vMware ESXi

Cause

As the physical switch has Etherchannel configured and Route Based on Originating Virtual Port is the default load balancing method on the vSphere Standard Switch after host install the diference in balancing will lead to connectivity loss intermitently or total.

Resolution

Change the portgroup or vSwitch balancing to iphash:

  1. Using cli: esxcli network vswitch standard portgroup policy failover set -p "Management Network" -l iphash 
  2. Using the UI: 
    1. In the vSphere Client, navigate to the host.
    2. On the Configure tab, expand Networking and select Virtual Switches.
    3. Navigate to the Teaming and Failover policy for the standard switch, or standard port group.
    4. From the Load balancing drop-down menu, select 'Route based on IP hash'.

Additional Information

Understanding IP Hash load balancing
Specifying or changing the load balancing policy from the command line in ESXi
Intermittent network connectivity on ESXi or host disconnect issues