Error "Cannot complete login due to an incorrect user name or password" when runing upgrade precheck on workload domain
search cancel

Error "Cannot complete login due to an incorrect user name or password" when runing upgrade precheck on workload domain

book

Article ID: 418206

calendar_today

Updated On:

Products

VMware SDDC Manager VMware Cloud Foundation

Issue/Introduction

  • Running a precheck on the workload domain fails with below error:

Cannot connect to vcenter. Cause: Cannot complete login due to an incorrect user name or password.

  • In the /var/log/vmware/vcf/commonsvcs/vcf-commonsvcs.log on the SDDC manager, you will entries similar to:

ERROR [common, 691565e070c24d8ef76045597fd4dbf2,161f] [c.v.e.s.c.c.v.vsphere.VcManagerBase,cs—exec—3] Cannot complete login due to incorrect credentials: vCenterfqdn, svc-#######
ERROR [common, 691565e070c24d8ef76045597fd4dbf2, 161 f] [c.v.v.i.sync.uti1s.VcSyncManagerUti1,cs—exec—3] Error connecting to vCenter with exception { } 
java.util.concurrent.ExecutionException: (vim. fault . InvalidLogin) { 
    faultCause — null, 
    faultMessage = null 

Caused by: com.vmware.vim.binding.vim.fault.InvalidLogin: Cannot complete login due to incorrect user name or password.

Environment

VMware Cloud Foundation 5.x

Cause

This issue occurs when there is a mismatch of vCenter service account password in SDDC Manager and vCenter Server

Resolution

To resolve the issue, contact Broadcom support for assistance