"BackupManager encountered an exception. See logs for details." an error occurred during the backup process for vCenter Server.
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"BackupManager encountered an exception. See logs for details." an error occurred during the backup process for vCenter Server.

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Article ID: 416802

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

  • Both scheduled and manual backups for the vCenter Server fail with the following error:


  • The backup logs at /var/log/vmware/applmgmt/backup.log of the vCenter Server, reveal that the process attempts to resolve the PNID via nic1, which lacks a valid IP configuration, instead of using the default interface nic0.

    YYYY-MM-DDTHH:MM:SS [] [MainProcess:PID-#######] [BackupManager::main:BackupManager.py:618] INFO: Starting backup job...
    YYYY-MM-DDTHH:MM:SS [] [Process-7:PID-#######] [detwist::_resultCB:detwist.py:94] DEBUG: Method result = {'interfacesInfo': [{'name': 'nic0', 'status': 'up', 'mac': ''}, {'name': 'nic1', 'status': 'up', 'mac': ''}]}
    YYYY-MM-DDTHH:MM:SS [] [Process-8:PID-#######] [detwist::_resultCB:detwist.py:94] DEBUG: Method result = {'config': [{'interface': 'nic1', 'mode': 'static', 'address': 'IP-address', 'prefix': 24, 'defaultGateway': '', 'updateable': True}, {'interface': 'nic0', 'mode': 'unconfigured', 'address': '', 'prefix': 0, 'defaultGateway': '', 'updateable': True}]}
    YYYY-MM-DDTHH:MM:SS [] [MainProcess:PID-#######] [Net::GetPNIDAddrInfo:Net.py:657] INFO: PNID 'vCenter FQDN' is resolved with addresses: ['IP-address']
    YYYY-MM-DDTHH:MM:SS [] [MainProcess:PID-#######] [BackupManager::GenerateBackupMetadata:BackupManager.py:220] ERROR: PNID is not resolvable to any IP on the existing system
    YYYY-MM-DDTHH:MM:SS [] [MainProcess:PID-#######] [BackupManager::main:BackupManager.py:645] ERROR: BackupManager encountered an exception: name 'MetadataException' is not defined
    YYYY-MM-DDTHH:MM:SS [] [MainProcess:PID-#######] [BackupManager::main:BackupManager.py:672] INFO: Backup job failed.

Environment

vCenter Server 7.x
vCenter Server 8.x

Cause

  • The issue occurs from nic0 lacking a valid IP configuration, prompting vCenter Server to reroute the backup through nic1. However, nic1 also fails to resolve to the vCenter PNID, resulting in backup failure. This network misconfiguration causes backup traffic to be misrouted, disrupting both automated and manual backup processes.
  • IP configuration can be validated by running ifconfig in vCenter SSH.

Resolution

VAMI backups succeed when the PNID is resolved through nic0, the default and primary network interface for the vCenter Server Appliance.

Note: Before proceeding with the steps below, take a snapshot of the vCenter Server.
Snapshot Best practices for vCenter Server Virtual Machines

Follow the steps below to resolve the issue:

  • Remove nic1 from the vCenter Server.
  • SSH into the vCenter VM as root.
  • Use the vami_config_net utility to assign a valid IP address and gateway to nic0.
  • Run ifconfig to confirm that nic0 reflects the correct network settings.
  • Retry the Backup.
  • Initiate a manual VAMI backup and verify that it completes successfully.

Additional Information

Changing IP address of VCSA using VAMI fails with "Unable to save settings. Check internet connection and server status"

Note: If nic1 is used for VCHA, destroy the existing VCHA configuration before implementing the steps above. Once the steps are successfully completed, reconfigure VCHA.
Remove a vCenter HA Configuration