Changing IP address of VCSA using VAMI fails with "Unable to save settings. Check internet connection and server status"
search cancel

Changing IP address of VCSA using VAMI fails with "Unable to save settings. Check internet connection and server status"

book

Article ID: 392200

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

The following error is seen after attempting changing IP address of vCenter through VAMI:

Environment

VMware vCenter Server 8.0.x

Cause

VAMI fails to apply IP changes due to network or DNS misconfigurations

Resolution

To resolve the issue of changing the IP address of the VCSA via VAMI page, follow these steps:

    • Take a snapshot of the vCenter VM before proceeding.
    • Use the following command to change the IP address directly from the VCSA's shell:
      # /opt/vmware/share/vami/vami_config_net
    • Select Option 6 to change the IP address:

    • Change the port group assignment for the VCSA directly on the ESXi host (make sure to update the ephemeral port group, if applicable).
    • Update the DNS record with the new IP address on the DNS server.
    • After changing the IP address and DNS record, reconnect to the VCSA via SSH from another server on the same subnet.
    • If necessary, change the default gateway using Option 2 in the vami_config_net tool (above command).

Once these steps are complete, the IP address settings should be validated, and you should be able to connect to the VCSA without issues.