Apply certificate option is not found in NSX
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Apply certificate option is not found in NSX

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Article ID: 416689

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Updated On:

Products

VMware NSX

Issue/Introduction

  • Replacing API/VIP certificate with CA certificate is facing issue
  • Certificate Signing Request (CSR) was generated from the NSX Manager
  • After importing the CA signed certificate to NSX, the "Apply Certificate" option is not available in the NSX UI 
  • The imported CA signed certificate category is displayed as Service

Environment

VMware NSX 4.2

Cause

This issue occurs when the Service Certificate option is selected while importing the signed certificate into NSX.

Resolution

  • To resolve the issue, delete the previously imported certificate from NSX and reimport it without selecting the Service Certificate option.



  • Note: NSX service certificates are user-facing for services such as load balancer, VPN, and TLS Inspection.

Additional Information

How to Replace NSX Manager Certificates Using CA-Signed Certificates in NSX 4.x

If this KB article does not address your issue or you have additional questions, please raise a support ticket with Broadcom Support and select NSX as the product.

Handling Log Bundles for offline review with Broadcom support.