Resetting the Root Password on VMware Data Services Manager Appliance
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Resetting the Root Password on VMware Data Services Manager Appliance

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Article ID: 416649

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Updated On:

Products

VMware Data Services Manager VMware Data Services Manager for VCF

Issue/Introduction

After the root password has expired, the UI warning will no longer be visible, but it will still be visible in the System Audit event list (you may need to scroll through pages to find it there to confirm). Other errors may also be seen in the UI when taking certain actions, similar to the following:

Below is a sample of a possible error displayed in the DSM UI as a result of root password expiry while customers attempt to enable a data service versions (MySql or Postgres or SQL Server) under Versions and Upgrades, when logged in as a DSM Administrator. Similar (though not exact) errors may be displayed in the UI when other actions are taken while the root password is expired. Checking the System Audit or DSM Provider logs will confirm if this is the root cause of errors.

"dataservicesversions.releases.dataservices.vmware.com" denied the quest: failed to read provider version: undefined response type.

 

Environment

DSM

Cause

The root account is disabled by default for DSM appliance , customers need to ensure that root account is activated (As needed) and password does not expire.

Resolution

This article outlines the steps to reset the SSH root password on the VMware Data Services Manager (DSM) appliance, both before and after password expiry.

Step 1: To reset the appliance root password before it expires, please following the instructions as mentioned below:

 

  1. You can reset the SSH root password of the VMware Data Services Manager appliance.
  2. Establish an SSH connection to the Provider VM as the root user.
  3. Execute the following command:
    passwd
  4. Enter the new password and confirm it.
  5. Log out and SSH back into the appliance using the new password.

Step 2: Reset the expired appliance root password, using the following instructions:

  1. You can reset the expired SSH root password of the VMware Data Services Manager appliance.
  2. Execute the following command:
  3. ssh root@<provider-ip>
  4. Enter the current password.
  5. Enter the new password and confirm it.
  6. Or users can login via the web console but need access to vCenter, followed by step 2 and step 3 above. 

 

Step 3: Reset a locked or unknown appliance root password

 

Note: You can reset the SSH root password of the VMware Data Services Manager appliance if it becomes locked or unknown.

If the appliance root password is locked or unknown, please refer the following KB 325916