Resetting the root password on a Photon appliance in VMware Aria Automation 8.x
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Resetting the root password on a Photon appliance in VMware Aria Automation 8.x

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Article ID: 325916

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Updated On: 04-23-2025

Products

VMware Aria Suite

Issue/Introduction

Resetting or recovery of a lost root password.

Environment

VMware vRealize Automation 8.x

VMware vRealize Orchestrator 8.x

VMware Aria Automation 8.x

VMware Aria Automation Orchestrator 8.x

Cause

Forgotten root password or "Too many authentication failure" error not allowing to login as root user.

Resolution

Prerequisites

  • You have valid snapshots or backups of the node(s) participating in the cluster.

Procedure

  1. Restart your VMware Aria Automation 8.x appliance and wait for the Photon OS Splash screen during boot.
  1. Enter 'e' to go to GNU GRUB boot menu editor:
  1. Add the below string behind the line that starts with linux: init=/bin/bash
  1. Enter F10 to boot the changed Entry.
  1. Mount the / partition as RW with mount -o rw,remount / and reset the root password with the passwd command:
  1. Validate the root account is not locked out and unlock if necessary:
           
    To check status of root account until Aria Automation 8.16.x use pam_tally2
    pam_tally2 -u root
    If locked run:
    pam_tally2 -u root --reset
    For Aria Automation 8.18.x and beyond use faillock.
    faillock --user root
    If locked run:
    /usr/sbin/faillock --user root --reset

    • If the faillock or pam_tally2 commands fail with: 
pam_tally2: Couldn't create /var/log/tallylog: No such file or directory
pam_tally2: Authentication error
    • Ensure there is enough space on /var/log.
      • The most common cause to this issue is vco_<date>_<time>_heap_dump.hprof files consuming the space.
        Remove these files using the following command:
        find / -iname "*hprof" 2>/dev/null -exec rm {};

     7. Reboot the appliance with the reboot -f command.

Additional Information

If there are still issues with resetting, refer to the Aria Operations reset KB and leverage the chart to continue troubleshooting this issue: How to Reset the Root Password in VMware Aria Operations (formerly vRealize Operations)