Accessing the vCenter UI results in a circle spinning on the screen, and the UI is never loaded
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Accessing the vCenter UI results in a circle spinning on the screen, and the UI is never loaded

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Article ID: 416091

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

  • When attempting to access the VCSA UI, the browser does not display any output or is stuck at a loading circle. However, access to the VAMI and SSH work as expected (both via IP and FQDN).
  • Opening the Chrome debugger using the F12 key and reviewing the network tab for connections, the following message will be seen:

logging(pending)

  • Error message after the UI loads for about 10 to 12 minutes :

[400] An error occurred while processing the authentication response from the vCenter Single Sign-On server. Details: Status:urn:oasis:names:tc:SAML:2.0:status:Requester, sub status: null.

  • vCenter server /var/log/vmware/vsphere-ui/logs/vsphere_client_virgo.log will have the following entries :

com.vmware.vim.vmomi.client.exception.ConnectionException: http://localhost:1080/external-vecs/http2/<vCenter-FQDN>/443/sso-adminserver/sdk/<example.local> invocation failed with "java.net.SocketTimeoutException: Read timed out".

  • No session exhaustion is seen in /var/log/vmware/vpxd/vpxd.log.

Cause

  • DNS server is not able to resolve the vCenter FQDN.
  • Recent changes to the DNS servers, such as DNS server migration to different geographical locations.

Resolution

  • Change the DNS to the native one where the forward and reverse lookups are working.
  • To change the DNS entry on the vCenter from the VAMI page
    • Log in as the root user to the vCenter Server Appliance Management Interface (VAMI) and navigate to Networking > Edit network settings
    • Enter DNS settings manually in the edit screen.
      If the DNS server was migrated: Enter the existing DNS server addresses.
      If using a new DNS server: Provide the new DNS server IP which is closer in geographical location to the vCenter server.

Additional Information

When session exhaustion is seen in the vCenter server /var/log/vmware/vpxd/vpxd.log below Broadcom KB article will come in handy :

 

vCenter UI アクセス時に読み込み中のまま画面が表示されない