Accessing the vCenter GUI results in a circle spinning on the screen, but no GUI ever comes up
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Accessing the vCenter GUI results in a circle spinning on the screen, but no GUI ever comes up

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Article ID: 406110

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

When attempting to access the VCSA GUI, the browser does not display any output or only a loading circle, but access to the VAMI and SSH work as expected.

Opened the Chrome debugger using the F12 key and then reviewing the connections we can see the message being repeated:

net::ERR_ADDRESS_IN_USE

Environment

vCenter 7.x
vCenter 8.x

Cause

This cause/issue is different than described in KB: HTTPS Connection Exhaustion in envoy logs of the vCenter server.

This issue is due to the max_active_downstream_connections value inside of the set to too low for the environment.

Resolution

Workaround 1:

Find the clients/IPs that are connecting to the vCenter and not reusing connections:

# zgrep /var/log/vmware/envoy/envoy-access-*.log.gz | cut -d ' ' -f 18 | cut -d ':' -f 1 | sort | uniq -c | sort -nr | head

Work with the respective vendor to reduce the connection count and/or reuse existing connections so that the limit won't be reached.

Workaround 2:

Change the max_active_downstream_connections inside of the envoy config.yaml file and increase the value.

Find the current number of connections for max_active_downstream_connections inside the envoy config file:

# cat /etc/vmware-envoy/config.yaml | grep max_active_downstream_connections
        max_active_downstream_connections: 8000

Increase the max_active_downstream_connections value from 8000 (default) to 14000:

# sed -i 's/max_active_downstream_connections: 8000/max_active_downstream_connections: 14000/g' /etc/vmware-envoy/config.yaml

Restart the envoy service for the change to take effect:

# service-control --restart envoy