ESXi Host summary page displays alerts "System logging is not configured on host <Host Name>"
search cancel

ESXi Host summary page displays alerts "System logging is not configured on host <Host Name>"

book

Article ID: 414815

calendar_today

Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

  • Summary Tab of ESXi on vSphere Client displays warning "System logging is not configured on host <Host Name>."

  • /var/run/log/vobd.log on ESXi host

YYYY-MM-DDTHH:MM:SS In(14) vobd[<PID>]:  [GenericCorrelator] ##us: [vob.user.vmsyslogd.storage.logdir.invalid] The configured log directory /vmfs/volumes/<datastore UUID>/log cannot be used. The default directory /scratch/log will be used instead.
YYYY-MM-DDTHH:MM:SS In(14) vobd[<PID>]:  [UserLevelCorrelator] ##us: [vob.user.vmsyslogd.storage.logdir.invalid] The configured log directory /vmfs/volumes/<datastore UUID>/log cannot be used. The default directory /scratch/log will be used instead.
YYYY-MM-DDTHH:MM:SS In(14) vobd[<PID>]:  [UserLevelCorrelator] ##us: [esx.problem.vmsyslogd.storage.logdir.invalid] The configured log directory /vmfs/volumes/<datastore UUID>/log cannot be used.  The default directory /scratch/log will be used instead.

Environment

VMware vSphere ESXi 7.x 
VMware vSphere ESXi 8.x
VMware vSphere ESX 9.x

Cause

This alert implies that a managed ESXi hosts is configured to send its logs to a specific datastore that it can no longer access.

Resolution

Proceed with the below steps to update the syslog configuration on the host

  • Log in to the vCenter Server using vSphere Client
  • Select the affected host in the inventory
  • On the right pane Click on Configure -> Advanced System Settings
  • Click Edit and search for the parameter "Syslog.global.logDir"
  • Under Value column update with the below string and click OK

[] /scratch/log

 

Additional Information

Refer Configuring syslog on ESXi