vSAN Performance screen intermittently hangs or times out.
search cancel

vSAN Performance screen intermittently hangs or times out.

book

Article ID: 414477

calendar_today

Updated On:

Products

VMware vSAN

Issue/Introduction

  • vSAN Performance screen intermittently does not display vSAN cluster performance data.
  • vSAN master host vsanmgmt.log displays the following message frequently.

   YYYY-MM-DDTHH:MM:SS Z In(14) vsand[345407947]: [opID=WorkQueue-#-#-# statsdb::ExecuteSqlAndWait] Mode: normalMode ExecuteSqlAndWait queue is full and timeout after 40 seconds

   To check the vSAN master host, run the following command on the all of ESXi host in vsan cluster.

           $ esxcli vsan cluster get | grep "Local Node State"
          Local Node State: MASTER

  • Pulling vSAN performance data via PowerCLI may display the same behavior.
  • VMware Aria Operations collecting data from the affected vSAN clusters may also display significant delays in returning results.

Environment

vSAN

VMware Aria Operations

Cause

Prior to vSphere 8.0 U3, the querying mechanisms leveraged by VMware Aria Operations to target vSAN performance metrics was not optimized thus intermittently causing "queue is full" conditions.  This would lead to a delay in pulling the statistics and/or displaying the statistics in the UI.

Resolution

Upgrading vCenter and the ESXi hosts to at least 8.0U3 should allow for optimized multi-entity queries to be used thus reducing the strain on vSphere and vSAN.

Post the upgrade, should the vSAN Performance screen still display significant delays in populating the data, VMware Aria Operations collection strategies can be re-evaluated.  Should assistance be needed please engage Global Support.

Additional Information