Host Monitor All Issues page reports "Quick stats on "HOSTNAME" is not up-to-date" and Advanced Performance page shows “No performance data is available for the currently selected metrics”
search cancel

Host Monitor All Issues page reports "Quick stats on "HOSTNAME" is not up-to-date" and Advanced Performance page shows “No performance data is available for the currently selected metrics”

book

Article ID: 414074

calendar_today

Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

Information about an ESXi host fails to update in vCenter Server.

You may observe the following symptoms:

  • On the Monitor > All Issues page of the host in vCenter, the following message appears:

    Quick stats on "<Hostname>" is not up-to-date

  • On the Monitor > Advanced Performance page, the following message is displayed:

    No performance data is available for the currently selected metrics

  • The ESXi host may become unresponsive, and host-related tasks appear stuck.

  • Restarting the hostd and vpxa services does not resolve the issue.

Environment

 

  • VMware ESXi 7.0

  • VMware ESXi 8.0

 

 

Cause

The issue occurs because the ESXi host becomes unresponsive(host-related tasks appear stuck), preventing communication and synchronization between the host and vCenter Server.

Resolution

To resolve this issue, restart the affected ESXi host.
This action resets the host environment and restores communication with vCenter Server.

Additional Information

For more details about the “Quick stats on <Hostname> is not up-to-date” error message, refer to:: Host Summary page reports "Cannot synchronize host" or "Quick stats on <Hostname> is not up-to-date"