Description not shown for device in DX NetOps CA Performance Management (CAPM)
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Description not shown for device in DX NetOps CA Performance Management (CAPM)

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Article ID: 413647

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Updated On:

Products

Network Observability CA Performance Management

Issue/Introduction

Some device are not showing anything in their description field in CAPM. For example:

Environment

DX NetOps CAPM all currently supported releases

Cause

DX NetOps get's the System Description from the SysDescr OID 1.3.6.1.2.1.1.1.0 value returned by the device in it's MIB data when it is discovered via SNMP.  So if the SysDescr OID is blank, then the issue is with the device. You can use snmpwalk to query the OID directly or get a full MIB walk by using the Sapwalk2 utility. Using sapwalk2 and starting the MIB walk at the base of the device MIB tree - 1.3.6.1, the first line returned will be the SysDescr OID , as per:

#sapwalk2: ver 25.0

#Copyright (c) 1994-2021 SIMPLESOFT Inc.

#Address=192.168.0.1, StartOid=1.3.6.1

#TimeOut=3000, MaxRetries=3, CompareFlag=0

#args: -I 192.168.0.1 -v v3 -s 1.3.6.1 -u xxxxx -l AP -xt SHA -xa xxxxx -xe AES128 -xp xxxxx -t 3000 -o MIB_walk.out 

1.3.6.1.2.1.1.1.0             , OctetString , 


Without a value, from the device, then PM will show a blank as well.

Resolution

You will need to check with the device's administrator on why the device's SNMP agent is showing a blank for the SysDescr OID 1.3.6.1.2.1.1.1.0  in it's MIB data.