Infrastructure Manager (IM) crashes: NimBUSManager.exe / Faulting module path: ucrtbase.dll
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Infrastructure Manager (IM) crashes: NimBUSManager.exe / Faulting module path: ucrtbase.dll

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Article ID: 413553

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

Your Infrastructure Manager (IM) is crashing and a Windows application Event 100 is triggered: 

 

 

Event 1000, Application Error

Faulting application name: NimBUSManager.exe, version: 2.0.4.6, time stamp: 0x649c3c43
Faulting module name: ucrtbase.dll, version: 10.0.17763.6189, time stamp: 0xb97939c6
Exception code: 0xc0000005
Fault offset: 0x0004d0dc
Faulting process id: 0x990
Faulting application start time: 0x01dc311c44d43113
Faulting application path: C:\Program Files (x86)\Nimsoft\bin\NimBUSManager.exe
Faulting module path: C:\Windows\System32\ucrtbase.dll
Report Id: f31eae66-a383-4fe7-b422-f0917c3e97f6
Faulting package full name: 
Faulting package-relative application ID:

Environment

DX UIM 23.4.*

Cause

Antivirus (such as CrowdStrike Falcon Sensor Service / Microsoft Defender Antivirus) scans can be the cause of this application crash

Resolution

To resolve this issue:

 

  1. Ensure that no Antivirus or Software prevention system is blocking the IM process.

    Follow the recommendations on the following article: Antivirus scanning of DX UIM components
    Note: For each Nimsoft administrator/Windows user running the Infrastructure Manager client application, the %Temp%\util folders should also be excluded.

  2. Uninstall IM completely. 

     From Control Panel->Programs and Features, uninstall the following 2 programs on the IM client:

    •  Nimsoft Infrastructure Manager
    •  .SOAP-runtime-TK3

  3. Download the latest IM version for the correspondent DX UIM Server version. 


    For example, if running DX UIM 23.4.3 (CU3), download and install Infrastructure Manager 23.4.3. 
    Note: You can download IM from http://<dxuim_server_ip>/uimhome  >> GO to downloads >> download IM 

  4. Reboot the IM Client machine and check again.  

 

Additional Information