HCX 4.11.3 upgrade fails with an error: "HCX no longer supports WANOPT from the 4.11.3 release."
search cancel

HCX 4.11.3 upgrade fails with an error: "HCX no longer supports WANOPT from the 4.11.3 release."

book

Article ID: 413318

calendar_today

Updated On:

Products

VMware HCX

Issue/Introduction

  • HCX upgrade to 4.11.3 fails with the following error in the UI: 
    Cannot continue upgrade due to errors : HCX no longer supports WANOPT from the 4.11.3 release. It is mandatory to remove WANOPT service from the existing Service Meshes and Compute Profiles. Compute Profiles: { ‘<Compute Profile NAME>’ } Service Meshes: { ‘<Service Mesh Name>’ } . Please correct before proceeding.
  • Error seen via HCX Admin UI 9443 page:



  • /common/logs/upgrade/upgrade.log show the following error:
    <timestamps> HCX is not supporting WANOPT from 4.11.3 release. It is mandatory to remove the WANOPT service from the existing Service Meshes.  [ FAIL ]
  • HCX upgrade from the VMC portal will fail with the following error. 
    HCX is not supporting WANOPT from 4.11.3 release. It is mandatory to remove the WANOPT service from the existing Service Meshes.}, status=Upgrade failed.

Environment

HCX 4.11.2 or lower

Cause

With the HCX 4.11.3 release, the WAN optimization feature is no longer available.

Resolution

  • Before upgrading to HCX 4.11.3, users must remove all existing WAN-OPT appliance services from the Compute Profile and Service Mesh. The upgrade will not proceed until the WAN-OPT appliance is removed from all the Service Meshes deployed in a given HCX Connector/Cloud System.
  • For new installations, the WAN-OPT service tile is no longer available under the Compute Profile and Service Mesh.
  • Please refer HCX Release Notes - VMware HCX 4.11.3 Release Notes

Workaround

Follow the steps in the KB "Deprecation of WAN Optimization in VMware HCX" to remove WAN Optimization from the service mesh and compute profile. 

Additional Information