Deprecation of WAN Optimization in VMware HCX
search cancel

Deprecation of WAN Optimization in VMware HCX

book

Article ID: 407101

calendar_today

Updated On:

Products

VMware HCX

Issue/Introduction

Currently, HCX systems utilize an WAN Optimization service, facilitated by the WAN-OPT Appliance, which provides bandwidth shaping and Data Deduplication/compression functionalities for migration traffic optimization. This document provides guidance on how to address this change and ensure continuity in workload migration operations.

Impact of Decommissioning:
HCX deployments utilizing the WAN-OPT service alongside the IX (Migration Appliance) will experience a loss of functionality. Specifically:

  • The existing WAN-OPT appliance will cease to function, and the tunnel between the source and target WAN-OPT Appliances will go down.
  • Any ongoing migration traffic utilizing the WAN-OPT appliance through the service mesh/IX Appliance may start dropping traffic, which could impact migration operations.

Note: The WAN-OPT Appliance is used mainly with the IX Appliance to optimize migration traffic per Service Mesh. It is not used for optimizing data traffic over the extended network via the HCX NE (Network Extension) Appliance.

Service Decommissioning Schedule:
The timing for service disablement depends on deployed HCX release in the field:

  • For versions up to HCX 4.11.0, the service will be disabled and non-functional starting November 30, 2025.
  • For versions HCX 4.11.1 to 4.11.2, the service will remain available until December 31, 2025, after which it will no longer be functional.

Note: The WAN-OPT Appliance functionality has already been removed for HCX versions 4.11.3 and VCF 9.0.

Environment

VMware HCX

 

Cause

The HCX WAN-OPT Appliance service will be decommissioned.

Resolution

To avoid service disruption, customers using WAN-OPT service are advised to upgrade to HCX 4.11.3 as soon as possible.

  1. Upgrade Planning:

    • Customers currently running versions up to 4.11.0 should upgrade to 4.11.3 as early as possible.
    • Customers using versions 4.11.1 or 4.11.2 should plan to upgrade before December 31, 2025.
    • If users have planned migrations using a service mesh with a deployed WAN-OPT appliance, users need to plan migrations after the WAN-OPT Appliance has been removed and/or after HCX Systems have been upgraded to 4.11.3.

  2. Actions for Ongoing Migrations:

    For customers with ongoing migrations that have scheduled switchover/maintenance windows after the respective deprecation dates (November 30 for 4.11.0/older; December 31 for 4.11.1/4.11.2):

    • Perform a forced migration switchover before the service reaches its deprecation date.
    • Alternatively, cancel the migration and re-trigger it after removing the WAN-OPT Appliance and/or upgrading to HCX 4.11.3.

  3. Steps Before Upgrading to 4.11.3:

    When upgrading to version 4.11.3, implement following steps in order:

    1. Remove WAN-OPT Appliances: Before upgrading the HCX Manager, need to first remove all existing WAN-OPT Appliances from all service meshes.

      This can be done by navigating to:

      HCX Standalone/443 UI → Interconnect → Service Mesh — unselect WAN-Opt service, which will trigger un-deployment of WAN-OPT Appliance VM from both source and target HCX Managers.

    2. Deselect WAN-OPT Appliance: After removal, deselect the WAN-OPT appliance from all Compute Profiles including HCX Connector and Cloud systems. This action removes the WAN-OPT service configuration from the management plane.

      HCX Standalone/443 UI → Interconnect → Compute Profiles — unselect WAN-Opt service

Note: Users are required to perform above operation from HCX Connector Or source HCX Cloud Manager for a cloud to cloud deployment.

Important Note: Attempting to upgrade the HCX Manager to version 4.11.3 with a WAN-OPT appliance Or configuration in the Compute Profile still present will result in a failed upgrade.
Users will be notified with below errors during pre-check under the HCX Connector/Cloud upgrade wizard.

The resolution is to follow the removal steps outlined above before attempting the upgrade again.

If you believe you have encountered this issue and are unable to upgrade, please open a support case with Broadcom Support and refer to this KB article.
For more information, see Creating and managing Broadcom support cases.

Additional Information

Refer HCX 4.11.3 Release Notes