Symantec Protection Engine API /spe/api/v1/product-status returns incorrect <isLicensed> status
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Symantec Protection Engine API /spe/api/v1/product-status returns incorrect <isLicensed> status

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Article ID: 413286

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Updated On:

Products

Protection Engine for Cloud Services

Issue/Introduction

When using Symantec Protection Engine (SPE) rest API /spe/api/v1/product-status to get product license details, the <isLicensed> field returns wrong information about the license status.

Environment

Symantec Protection Engine 9.x

Cause

If a license is in the Warning Period (Within 60 days of expiration), the API /spe/api/v1/product-status is misreporting the license as no longer valid.

Resolution

A license in the Warning Period is still valid.

Workaround

There are two alternative methods for verifying SPE's license status.

Using a different API

The SPE API /spe/api/v1/homepage-statistics also returns License information and can be used instead of the API mentioned above that's returning false information.

Using report.xml

The license status can be confirmed by looking at the <Licensing> section of report.xml.  This file can be found in

  • Windows: C:\Program Files\Symantec\Scan Engine\report.xml
  • Linux:  /opt/SYMCScan/bin/report.xml

If the report.xml shows the license is still valid it can continue to be used normally.

Solution

A fix for this issue is targeted for release in SPE 9.3.1 with an ETA of end of March 2026.

Additional Information