The migrated VM's hard disk is incorrectly linked to the wrong cloud account in Aria Automation.
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The migrated VM's hard disk is incorrectly linked to the wrong cloud account in Aria Automation.

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Article ID: 412944

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Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

  • After vMotion of a VM from one vCenter to another, within Aria Automation the Hard Disks resources are mapped to old Cloud Account.
  • Confirm the "accounts" mapped to the "Hard Disk" resource for the migrated VM following the below path:
    Aria Automation Assembler >> Resources >> Select the "Hard Disk" mapped to the VM >> Expand "Custom properties"

Environment

VMware Aria Automation 8.x

Cause

The provisioning database holds a stale entry for the VM Hard Disk, which incorrectly lists the accounts.

Resolution

  • Deleting the old Cloud Account from Aria Automation UI automatically cleans the stale disk mapped to the "accounts" property in the database.
    1. Navigate to Infrastructure >> Connections >> Cloud Accounts.
    2. Select the old vCenter Cloud Account that is no longer in use and Click "DELETE".
  • If deleting old Cloud Account is not a feasible solution, to manually remove the stale entry raise a ticket with Broadcom support and reference this article id 412944.