Usage Meter Fails to Collect NSX Hourly Usage Report (HUR) Data: NSX-T Instance Certificate Not Accepted
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Usage Meter Fails to Collect NSX Hourly Usage Report (HUR) Data: NSX-T Instance Certificate Not Accepted

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Article ID: 411839

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Updated On:

Products

VMware Usage Meter

Issue/Introduction

Usage Meter is unable to retrieve NSX Hourly Usage Report (HUR) data for NSX-T instances. which are downloaded from the Business Service Console. This issue prevents accurate reporting and billing of NSX usage.

Environment

VMware Usage Meter 9.0
VMware NSX-T Data Center

Cause

The primary cause is that the NSX-T Manager instance's certificate has not been accepted within Usage Meter, or its status has reverted to an "unmetered" state, preventing successful data collection.

-collection-nsx-t-main.log
YYYY-mm-dd TT:MM:SS.NNN INFO --- [collector-main-thread] c.vmware.um.collector.CollectionHelper : No active metered servers found for the product :NSX-T

-var/dss/random/nsxt.json
{
  "lastChanged": 1749633627943,
  "vcHosts": [
    "XXXX.YYYY.ZZZZ"
  ],
  "unpinnedCertificates": "{\"WWW.XXX.YYY.ZZZ:443\":{\"notAfter\":1820912979000,...", <--- This indicates the certificate is not accepted
  "active": true,
  "inventory": [
    {
      "id": 1,
      "vc_instance_uuid": "******"
    }
  ],
  "version": "4.1.2",
  "password": "******",
  "licenses": "[...]",
  "port": 443,
  "host": "XXX.YYY.ZZZ",
  "forgotten": false,
  "metered": false, // <--- This indicates the instance is not metered
  "computeManagerHostnames": [
    "XXXX.YYYY.ZZZZ"
  ],
  "id": 3,
  "user": "admin",
  "productType": "NSX-T",
  "who": "Product"
}

 

Resolution

To resolve this issue, you need to delete the existing NSX-T instance registration in Usage Meter and then re-register it, ensuring the certificate is accepted during the process. After that , confirm collection is completed from Notification Tab.

Additional Information