"Error building authorization at null null" breaking SDM-PAM integration after RU update or running pdm_config
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"Error building authorization at null null" breaking SDM-PAM integration after RU update or running pdm_config

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Article ID: 410436

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Updated On:

Products

CA Service Management - Service Desk Manager CA Service Desk Manager CA Process Automation Base Process Automation Manager

Issue/Introduction

Following RU update, SDM to PAM integration is not working.  Trying to create a macro in SDM results in "Error building authorization at null null"

SDM server's jstd.log (SDM install log directory) indicates:

XX/XX XX:XX:XX.XXX [Thread-2] ERROR ItpamWorkflow 570 Error getting definitions:  
java.lang.Exception: Error building authorization at null null

Environment

Release:  All applicable and certified Service Desk/PAM integrations

Cause

The Service Desk Manager NX.env lacks the EEM settings needed to operate

Resolution

In a basic SDM/PAM integration instance, the following values should be present in the SDM Server's NX.env:

@NX_CAEXTWF_EEM_HOSTNAME=[EXAMPLE SERVER]
@NX_CAEXTWF_ENDPOINT=http://[EXAMPLE PAM SERVER]:8080/itpam/soap
@NX_CAEXTWF_LOG_CATEGORIES=Process,Operator
@NX_CAEXTWF_PROCESSDISPLAY_URL=http://[EXAMPLE PAM SERVER]:8080/itpam/Web.jsp?page=runtimeeditor&ROID=
@NX_CAEXTWF_WORKLIST_URL=http://[EXAMPLE PAM SERVER]:8080/itpam?page=tasklist
@NX_CAEXTWF_WS_PASSWORD=<OMITTED>
@NX_CAEXTWF_WS_USER=<OMITTED>

 

Review prior NX.env files to examine for the above variables, or re-run Options Manager to uninstall/reinstall the PAM based options.  For the latter, login to the SDM Classic UI as an Administrative user, under Administration tab, access Options Manager -> CA IT PAM Workflow.

In this particular scenario, the NX_CAEXTWF_EEM_HOSTNAME was missing.

Additional Information