SRA Adapter is not getting reflected or page is blank even after rescan
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SRA Adapter is not getting reflected or page is blank even after rescan

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Article ID: 410420

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Updated On:

Products

VMware Live Recovery

Issue/Introduction

1. srm-server service stops unexpectedly 

vmware-dr.log

20##-0#-13T06:33:53.517-04:00 error vmware-dr[02093] [SRM@6876 sub=Storage opID=d1724308-9e8c-4a67-9662-29dda0e1cad6-reloadAdapters:8589] Failed to create SRA log directory '/var/log/vmware/srm/SRAs/sha256_##########################################################'
20##-0#-13T06:33:53.518-04:00 verbose vmware-dr[02093] [SRM@6876 sub=Storage opID=d1724308-9e8c-4a67-9662-29dda0e1cad6-reloadAdapters:8589] Posting event to VC: (dr.eventEx.StorageAdaptReloadFailEvent) {
-->    installPath = "sradocker:10.2.0.1",
-->    fault = (dr.storage.fault.CannotLoadAdapter) {
-->       faultCause = (vmodl.fault.SystemError) {
-->          faultCause = (vmodl.MethodFault) null,
-->          faultMessage = <unset>,
-->          reason = "N2Dr7Storage3Sra27CannotCreateSraLogDirectoryE Cannot create SRA log directory '/var/log/vmware/srm/SRAs/sha256_############################################'.
--> [context]###############################################################################################################################################################[/context]
--> [backtrace begin] product: VMware vCenter Site Recovery Manager, version: 8.7.0, build: build-21589505, tag: vmware-dr, cpu: x86_64, os: linux, buildType: release
--> backtrace[03] libvmacore.so[0x001CA1ED]
--> backtrace[04] libdr-storage-sra.so[0x0010A226]
--> backtrace[05] libdr-storage-sra.so[0x00050995]
--> backtrace[06] libdr-storage-sra.so[0x001075BA]
--> backtrace[07] libdr-storage-sra.so[0x0008966A]
--> backtrace[08] libdr-storage.so[0x001888E0]
--> backtrace[09] libdr-storage.so[0x00178F4E]
--> backtrace[10] libdr-storage.so[0x00176C7B]
--> backtrace[11] libdr-storage.so[0x0015FA1A]
--> backtrace[12] libvmacore.so[0x0031014D]
--> backtrace[13] libvmacore.so[0x003118AD]
--> backtrace[14] libvmacore.so[0x0041250E]
--> backtrace[15] libpthread.so.0[0x00007F87]
--> backtrace[16] libc.so.6[0x000F362F]
--> [backtrace end]"
-->          msg = ""
-->       },
-->       faultMessage = <unset>,
-->       installPath = "sradocker:10.2.0.1"
-->       msg = ""
-->    }
--> }



2. Log bundles cannot be generated

3. The SRA log partition is full. 

root@srm [ ~ ]# df -h
Filesystem                      Size  Used Avail Use% Mounted on
devtmpfs                        4.0M     0  4.0M   0% /dev
tmpfs                           4.9G   44K  4.9G   1% /dev/shm
tmpfs                           2.0G  856K  2.0G   1% /run
tmpfs                           4.0M     0  4.0M   0% /sys/fs/cgroup
/dev/sda4                        14G  5.5G  7.4G  43% /
tmpfs                           4.9G  488K  4.9G   1% /tmp
/dev/sda2                       238M   36M  190M  16% /boot
/dev/mapper/support_vg-support  3.9G  555M  3.2G  15% /opt/vmware/support
/dev/loop0                      378M  358M     0 100% /opt/vmware/support/logs/srm/SRAs

Environment

VMware Site Recovery Manager 
VMware Live Site Recovery

Cause

Unmanaged SRM or SRA logs within the appliance can fill up support partition disk. This results in failure of the SRM server service because there's no space left on the disk for the services to write logs. 

The SRM appliance has two main disks: 
system and support.

The support disk is partitioned into lvm ext4 filesystem & is used to store the logs of VMware-related services. The mount point of the partition is "/opt/vmware/support"

Some SRAs (Storage Replication Adapter) lack an inbuilt log rotation & compression software or don't have a limit on the size of logs they produce. This will result in the unplanned failure of the SRM server services due to the lack of any space available on disk for the log files.

Resolution