Deleting a VM protected by vSAN Data Protection remains with 'null' vmdk objects
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Deleting a VM protected by vSAN Data Protection remains with 'null' vmdk objects

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Article ID: 410020

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Updated On:

Products

VMware vSAN

Issue/Introduction

  • After deleting a Virtual machine configured for vSAN Data protection, the vmdk objects associated with that VM show the Path as 'null'.

Example:
From ESXI CLI, run the command "esxcli vsan debug object list | less"

Object UUID: 5a3fb968-####-####-####-00505603269d
Version: 20
Health: healthy
Owner: esx-###.###.###.lab
Size: 20.00 GB
Used: 0.00 GB
.
.
Type:vdisk
Path:(null)
Group UUID:21e8a668-####-####-####-b483511f3118
Directory Name: N/A

Environment

VMware vSAN
vSAN Data Protection

Cause

This is because the Virtual machines are deleted before removing the snapshot associated with the VM in the Protection group.

Resolution

To remove the null vdisk objects, please contact Broadcom Support.

Steps to be followed to delete the VM which is part of protection group:

  1. Verify Protection Group Membership - Confirm that the VM is part of a vSAN Data Protection Protection Group.

  2. Check for Snapshots - In the vSAN Data Protection UI, verify if snapshots exist for the VM.

  3. Remove Snapshots - Delete all snapshots for the VM from the vSAN Data Protection UI.
    Note:This will remove all the snapshots associated with that protection group.

  4. Remove VM from Protection Group - From vSAN Data Protection, remove the VM from the associated Protection Group.

  5. Delete the VM from vCenter - In the vSphere Client, right-click the VM and select Delete from Disk.

  6. Validate Cleanup

    • esxcli vsan debug object list |grep -i "null"