Unable to configure Enhanced replication of VM. Error seen: "The virtual machine host does not support enhanced replication"
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Unable to configure Enhanced replication of VM. Error seen: "The virtual machine host does not support enhanced replication"

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Article ID: 409598

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

Symptoms:

  • When configuring VM replication to use enhanced replication, the following error is seen in the configuration wizard:

    "Some of the selected virtual machines are not in a valid state for replication"

    "The virtual machine host does not support enhanced replication"

  • The following error is seen when running the Enhanced Replication Mappings test on Site Recovery:

    "Fault occurred while performing health check. Details: '404 Not Found from GET https://<esxi_ip>/hbragent/api/v1.0/appPing?broker_ip=<vr_ip>&broker_port=32032&group=PING-GID-##########################'."

  • ESXi firewall does not list hbr-agent under outgoing connection.

Environment

VMware vSphere Replication 9.x

Cause

  • This issue is caused due the host on which the VM resides on does not have the hbr-agent vib installed on it.

  • Due to the vib being unavailable on the host, the host will not supported enhanced replication.

  • Also since the vib is not installed, the ESXi firewall will not list the hbr-agent under outgoing connection.

  • This can be validated by running the following command in an SSH to the ESXi host: esxcli software vib list | grep hbr

    Non-working host:
    root@host1:~] esxcli software vib list | grep hbr
    vmware-hbrsrv                  8.0.3-0.0.24022510                    VMware  VMwareCertified   2025-05-29    host

    Working host:
    root@host1:~] esxcli software vib list | grep hbr
    vmware-hbr-agent               8.0.3-0.0.24143343                    VMware  VMwareCertified   2025-01-02    host
    vmware-hbrsrv                  8.0.3-0.0.24022510                    VMware  VMwareCertified   2025-01-02    host

Resolution

To resolve this issue:

  1. If this is a new setup, it could be possible that the vib is not pushed to all (or any) hosts in the environment. The vSphere Replication's /opt/vmware/hms/conf/hms-configuration.xml file can be validated to see if the hbragent auto install is disabled (<hms-auto-install-hbragent-vib>false</hms-auto-install-hbragent-vib>). If it is disabled, perform the below:

    1. SSH to vSphere Replication appliance as root user.

    2. Type following command to edit the hms-configuration.xml and set the parameter's value to true: vi /opt/vmware/hms/conf/hms-configuration.xml

    3. Press 'i' and then change the configuration of parameter from 'false' to 'true': <hms-auto-install-hbragent-vib>true</hms-auto-install-hbragent-vib>

    4. Save the file by pressing: Esc + ':wq!'

    5. Finally, restart hms service on the VR appliance using command: systemctl restart hms

    6. Repeat the same steps on the other VR appliance as well.

  2. If this issue is only observed on a few hosts in the environment and if the above resolution does not fix the issue, manually install the vib on the ESXi host:

    1. Log into the VR appliance using WinSCP and navigate to the folder /opt/vmware/hbr/vib.
    2. Download the file named vmware-hbr-agent-######.vib
    3. Upload the file to the /tmp folder of the ESXi host with issue.
    4. Then install the vib using command: esxcli software vib install -v /tmp/vmware-hbr-agent-######.vib
      This does not require a reboot of the host.

Once the vib is installed on the host, the configuration of replication should work. If another error arises post performing this fix or if vSphere Enhanced replication is still not working, open a case with Broadcom Technical Support to investigate further.