HCX Mobility Groups deleted via API remain in "draft" state when using the new HCX GUI
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HCX Mobility Groups deleted via API remain in "draft" state when using the new HCX GUI

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Article ID: 407227

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Updated On:

Products

VMware HCX

Issue/Introduction

  • After mobility groups are deleted via API, they remain in the new UI on target HCX Manager. When looking at the legacy view, those mobility groups are no longer present. 
  • Unable to delete the Mobility Group in the new UI. Clicking on the 3 dots next to the mobility group produces no options. 

Environment

VMware HCX 4.11.x

Cause

  • There are lingering entries in the cloud/target HCX Manager database.
  • The new HCX UI uses a different set of API calls to retrieve certain datasets from backend as opposed to the "legacy view".

Resolution

  • On the target/destination HCX Manager, try deleting the mobility group via the "legacy UI". 
  • If the mobility group does not exist in legacy UI and only shows in the "new ui" please use the following API to retrieve the mobility group ID:
    • curl 'https://<Target hcx-manager ip or fqdn>/hybridity/api/v2/mobility-groups/query'   -H 'Accept: application/json'   -H 'Content-Type: application/json'   -H 'x-hm-authorization: <your x-hm token>'   --data-raw "{"pageParameters":{"sortBy":[{"field":"mobilityGroupCreationTime","direction":"DESC"}],"pageNumber":1,"pageSize":50,"totalRecords":150},"filter":{"migrationWaveId":null}}"   --insecure
  • Once the mobility group ID has been acquired, issue the delete command via the following API. The delete API should be issued on the HCX Manager showing the discrepancy via the UI.
    curl "https://<HCX_Manager_FQDN>/hybridity/api/mobility/groups/delete" -H "Accept: application/json" -H "Content-Type: application/json" -H "x-hm-authorization: <x-hm_token>" --data-raw "{"items":[{"migrationGroupId":"<MigrationId>"}]}"
  • Verify the mobility group no longer exists in the UI. 
  • If the above steps do not successfully remove the mobility group, please open a support case with Broadcom and provide the following information. 
    • Screenshots showing the discrepancy. 
    • Source/Connector HCX Manager logs w/DB dump.
    • Destination/Cloud HCX Manager logs w/DB dump.
    • Summary of all API calls used in trying to resolve this issue along with corresponding output.