Adding ESXi hosts to NSX Manager fails with error stating that a Transport Zone cannot be relocated from one HostSwitch another in a single transaction and to "Delete HostSwitch from current Transport Zone to add later to another Transport Zone"
search cancel

Adding ESXi hosts to NSX Manager fails with error stating that a Transport Zone cannot be relocated from one HostSwitch another in a single transaction and to "Delete HostSwitch from current Transport Zone to add later to another Transport Zone"

book

Article ID: 407043

calendar_today

Updated On:

Products

VMware NSX

Issue/Introduction

When adding an ESXi host to a cluster of NSX configured hosts in vSphere with a Transport Node Profile attached to the cluster, the NSX configuration begins in NSX Manager but then fails with an error message like:

9560: Transport Zone TransportZone/########-####-####-####-############ cannot be relocated from HostSwitch ## ## ## ## ## ## ## ##-## ## ## ## ## ## ## ## to HostSwitch <different UUID> in a single transaction. Delete HostSwitch from current Transport Zone to add later to another Transport Zone.

The details of the Validation Error in NSX Manager show the same message:

If you attempt to add the host again from the NSX Manager UI by selecting the host under System > Fabric, and clicking Configure NSX, it may fail with a different error message stating that a host with the same IP address already exists.

 

Environment

  • VMware NSX 4.x
  • VMware NSX-T Data Center 3.x

Cause

Stale data from a host that wasn't cleanly removed from NSX Manager in the past is still present and conflicts with the configuration of new ESXi transport nodes.

Resolution

Refer to the resolution steps provided in article Installing or Upgrading NSX on an ESXi host fails reporting the node already exists with steps to remove stale ESXi transport node data from NSX Manager.

If the ESXi host that is failing to configure is still in the cluster, place it into Maintenance Mode and drag it out of the cluster in vSphere before using the steps in the above article to force delete the old host data from NSX Manager.

Additional Information

Note that when selecting the host to 'Remove NSX', if doing it from the UI, it may show up under Standalone or Other hosts with the name of the new ESXi host if the name is different than what the old host used, and the name may change to the name of the old host in the box that pops up after selecting Remove NSX.

 

If you are contacting Broadcom support about this issue, in order to aid a timely response and resolution, please provide the following:

  • NSX version.
  • NSX Manager log bundles.
  • ESXi host log bundles for hosts that are failing to configure as transport nodes.
  • Text of any error messages seen in NSX GUI or command lines pertinent to the investigation and screenshot.

Handling Log Bundles for offline review with Broadcom support


Related Installation documentation: