LCMVMSP10002 error when deploying VCF Automation 9.0
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LCMVMSP10002 error when deploying VCF Automation 9.0

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Article ID: 406528

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Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

  • Deploying VCF Automation 9.0 from VCF Operations Fleet Management fails with error code LCMVMSP10002 . In the request flow chart under VCF Operations > Fleet Management > Lifecycle > VCF Management >Tasks > (vcfa deployment task) , we see the below error message :
    Task failure on Stage 8 shows issues similar to:
    Request Failed
    LCMVMSP10002
    Error Code: LCMVMSP10002
    Failed to deploy product on the application platform.
    Product deployment failed.


  • In Fleet management appliance, vmware_vrlcm.log shows log messages similar to:
    INFO vrlcm[####] [pool-3-thread-63] [c.v.v.l.p.a.s.Task]  -- Injecting task failure event. Error Code : 'LCMVMSP10002', Retry : 'true', Causing Properties : '{ CAUSE ::  }'
    com.vmware.vrealize.lcm.vmsp.common.exception.DeploymentFailedException: No failed pods found.
    and
    "localizedMessageId" : "LCM_VMSP_PKG_PUSH_ERROR_0001",
    and
    error: context deadline exceeded

Environment

VCF Automation 9.x
VCF Operations 9.x

Cause

This can be caused by capital letters in the defined fqdn during the deployment wizard.  

  • environment file in the failed vcfa log bundle shows:

    Helm upgrade failed for release prelude/vcfa-common with chart [email protected]: failed to create resource: HTTPRoute.gateway.networking.k8s.io "vcfa-common-default-route" is invalid: [spec.hostnames[0]: Invalid value: "CAPITALHOSTNAME.example.com" spec.hostnames[0] in body should match...
  • vmware_vrlcm.log can be searched for easy identification:

    Search for DEPLOYMENT_FAILED in the logs and in the section labeled "productId" : "vra"
    Look for "fqdn" and see if there are CAPITAL letters in the fqdn.

    {
      "productId" : "vra",
      "vcfInstances" : [ ],
      "componentDTO" : {
        "vmid" : "########-####-####-####-###########",
        "tenant" : "<tenantname>",
        "componentVmid" : "########-####-####-####-###########",
        "componentType" : "vra",
        "currentVersion" : "9.0.0.0",
        "environmentId" : "########-####-####-####-###########",
        "fqdn" : "CAPITALHOSTNAME.example.com",
        "componentStatus" : "FAILED",
        "engineRequestId" : "########-####-####-####-###########",
        "fleet" : true,
        "properties" : { },
        "references" : [ ],
        "status" : "DEPLOYMENT_FAILED",
        "action" : "VIEW_DETAILS",
        "compatibleVersions" : [ ]

Resolution

The provided FQDNs must be specified in lowercase during the Automation deployment wizard in VCF Operations > Fleet Management > Lifecycle.

Additional Information

If the provided FQDN is already in lowercase, then retry the failed request from VCF Operations > Fleet Management > Lifecycle > VCF Management > Tasks .

Gather the failed VCFA log bundle using: https://knowledge.broadcom.com/external/article/394146/generating-a-log-bundle-from-a-failed-vc.html

NOTE: The deployment of the SDDC appliance will fail if the DNS record for the SDDC Appliance contains uppercase characters.

See VMware Cloud Foundation deployment fails if the SDDC Manager FQDN includes uppercase letters