Generating a log bundle from a failed VCF Automation or VCF Identity Broker component deployment
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Generating a log bundle from a failed VCF Automation or VCF Identity Broker component deployment

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Article ID: 394146

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Updated On:

Products

VCF Automation VCF Operations

Issue/Introduction

When the deployment of a component fails, specifically VCF Automation and VCF Identity Broker, the option to generate a log bundle is not possible from the UI as the component is not registered yet.

Environment

  • VCF Automation 9.x
  • VCF Operations 9.x
  • VCF Identity Broker 9.x

Cause

Log bundles are required to capture diagnostic data when a VMSP install/upgrade request fails. These logs provide essential insights into the cause of the failure.

Resolution

Use the steps below to generate and download the log bundle from the failed VCF Automation or VCF Identity Broker deployment:

Prerequisites: 

  • Failure Context: VMSP install/upgrade failure occurring after deployment is completed in Fleet Manager
  • VMSP instance must still be available and accessible.
  • The failed environment should exist in Fleet Manager and be no older than 30 days.
  • Required inputs:
    environmentId (failed environment)
    requestId (failed request)
    Fleet Manager admin username (admin@local)
    Fleet Manager admin@local password
    Fleet Manager root password
    Folder path on the Fleet Manager to store the downloaded log bundle

Procedure:

  1. Log in to the Fleet Manager appliance as root via SSH or vSphere Console
  2. Download the logBundleSupport.sh script (attached to the bottom of this KB article)
  3. SCP copy the file to the Fleet Manager appliance in the /data directory
  4. Provide execution permission to the script:
    chmod +x /data/LogBundleSupport.sh
  5. Execute the script:
    /data/LogBundleSupport.sh

Additional Information

Ensure correct values for environmentId and requestId, which can be obtained from the VCF Operations UI or Fleet Manager API logs.

Log bundles are intended for VMware/Broadcom support to analyze and determine the root cause of failures.

 

Attachments

LogBundleSupport.sh get_app