Generating a log bundle from a failed VCF Automation & VCF Identity Broker component deployment
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Generating a log bundle from a failed VCF Automation & VCF Identity Broker component deployment

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Article ID: 394146

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Updated On:

Products

VCF Automation

Issue/Introduction

  • Generating a log bundle from a failed VCF Automation & VCF Identity Broker component deployment.
  • When the deployment of a component fails, specifically VCF Automation and VCF Identity Broker, we do not have the option to generate a log bundle from the UI, as the component is not registered yet.

Environment

  • VCF Automation 9.x
  • VCF Operations 9.x
  • VCF Identity Broker 9.x

Cause

Log bundles are required to capture diagnostic data when a VMSP install/upgrade request fails. These logs provide essential insights into the cause of the failure.

Resolution

Follow the steps below to generate and download the log bundle:

1. Prerequisites: 

  • Failure Context: VMSP install/upgrade failure occurring after deployment is completed in vRSLCM.
  • VMSP instance must still be available and accessible.
  • The failed environment should exist in vRSLCM and be no older than 30 days.
  • Required inputs:
    environmentId (failed environment)
    requestId (failed request)
    vRLCM admin username
    vRLCM admin password
    root password
    Folder path from the vRLCM terminal to store the downloaded log bundle

2. Procedure:

  • Log in to the vRSLCM instance terminal.

  • Download the script attached in this KB article and move it under the /tmp directory. 

  • Provide execution permission to the script:

    chmod +x LogBundleSupport.sh

  • Execute the script:

    ./LogBundleSupport.sh

Additional Information

Ensure correct values for environmentId and requestId, which can be obtained from the vRLCM UI or API logs.

Log bundles are intended for VMware/Broadcom support to analyze and determine the root cause of failures.

 

Attachments

LogBundleSupport.sh get_app