VMware Aria Suite Lifecycle 8.18 Patch 3 Installation Runbook
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VMware Aria Suite Lifecycle 8.18 Patch 3 Installation Runbook

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Article ID: 406032

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

This article outlines the complete set of steps required for customers to successfully install VMware Aria Suite Lifecycle 8.18 Patch 3.

IMPORTANT Pre-Patch Instructions

Before proceeding with any patching activity, please follow the steps below carefully to avoid service disruption:

1. Take Snapshots

Create non-memory snapshots of both VMware Identity Manager and VMware Aria Suite Lifecycle from vCenter while they are in a healthy state.

2. Patch VMware Identity Manager as a First Step:


You must patch VMware Identity Manager before VMware Aria Suite Lifecycle. Follow the instructions in the VMware Identity Manager patch article:

vIDM Patch - Knowledge Base Article 404054

     2.1. Validate Patch Readiness

     Only proceed with the VMware Identity Manager patch if the prepare-vidm-patch.sh script (available in the article above) returns the following message:
 
     "Done! You can now proceed with installing the vidm-patch."

     


3. Patch VMware Aria Suite Lifecycle

Once VMware Identity Manager is successfully patched, proceed with patching VMware Aria Suite Lifecycle as described in:

vRSLCM Patch - Knowledge Base Article 406032

4. Do Not Delete Snapshots Early

Retain the working state snapshots taken in Step 1 until both VMware Identity Manager and VMware Aria Suite Lifecycle patching processes are fully completed and verified.


Installing VMware Aria Suite Lifecycle 8.18.0 Patch 3, two types of issues have been observed. These are caused by either missing or conflicting RPMs or an unsupported entry in /etc/fstab.

The following errors may appear:


Error 1: Missing GPG Key for Repository

An error related to a missing GPG key may appear in the log file: /var/log/vrlcm/os-package-update.log

Example error:

chkconfig Error processing package: mpc-1.3.1-4.ph5.x86_64.rpm Error(1523): GPG key entry is missing for this repo. Please add the GPG key to the repo file or use --nogpgcheck to bypass the check. x86_64 1.21-3.ph5 photon-rpms 810.99k 830454

Error 2: Mount Failure

The patch may fail due to an unsupported /etc/fstab entry, resulting in the following error:

Failed to mount /boot

Environment

VMware Aria Suite Lifecycle 8.18.0

Cause

These issues are primarily observed in VMware Aria Suite Lifecycle environments that have been gradually upgraded from version 8.4.x to 8.18.0 over time.

Resolution

1. Take a snapshot of the VMware Aria Suite Lifecycle 8.18.x appliance (Mandatory)

2. Run the script attached to this KB article. Copy the attached script to /data and execute the script using below commands

cd /data

chmod +x prep-for-upgrade-lcm.sh

./prep-for-upgrade-lcm.sh

3. Download the patch 

  • Log in to the Broadcom Support Portal.
  • Click My Downloads and choose VMware Aria Suite
  • Click the Solutions tab and select VMware Aria Suite - Enterprise. Choose the 2019 release.
  • On the list of Product Support Packs and Patches, filter to find the appropriate patch and click it to open the download page.
    To search for a Patch, look for syntax in the format  vrslcm-8.18.0-PatchX.patch , where  X is the patch number.

    4. Copy the VMware Aria Suite Lifecycle  8.18 Patch 3 file onto /data of the appliance 

    5.  From the Lifecycle Operations dashboard, navigate to Settings > Binary Mapping and click Patch Binaries. If any binaries from a previous installation are listed, delete them. In Source Location, enter the path to the patch upload such as /data and click Discover Select the Patch discovered and click Add ,Once the source mapping is complete, proceed with installation of the patch.

    6. Go to Lifecycle Operations dashboard, navigate to Settings , System Patches  and then Install the Patch. 

    7. The patch installation takes around 20 minutes. So wait till the reboot of VMware Aria Suite Lifecycle occurs and it completely comes back. 

    Validation of Patch Completion in the VMware Aria Suite Lifecycle UI

    • Login to VMware Aria Suite Lifecycle UI and click on About and check if the Patch version is set to Patch 3
    • Check the Photon version using shell session to VMware Aria Suite Lifecycle appliance to check photon version
      cat /etc/photon-release
      VMware Photon OS 5.0
      PHOTON_BUILD_NUMBER=b9d98344d

     

        Additional Information

        Logs to Monitor

        /var/log/vrlcm/os-package-update.log
        /var/log/vrlcm/patchcli.log
        • When following this KB, even when completing all of the above steps under the resolution, when getting to step 9 you may still run into a space issue on the /tmp directory. You will know this by getting Error Code: LCMPATCHUPDATE16002.
        • If that is the case please refer to KB https://knowledge.broadcom.com/external/article/345990 to temporarily increase the space on the /tmp directory, allowing the package to be fully extracted and properly installed. 

        Attachments

        prep-for-upgrade-lcm.sh get_app