NSX host disconnected because NSX manager IP changed after restoring from a backup
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NSX host disconnected because NSX manager IP changed after restoring from a backup

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Article ID: 404907

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Updated On:

Products

VMware NSX

Issue/Introduction

If your restored NSX manager has a different IP address either because the DNS entry was changed or you assigned it a new IP address during the restore process the DNS cache on the host sometimes might not clear causing the host to be in a disconnected state. This results in the host rejecting communication from the new NSX manager and either showing different connection IP's when you run a get controllers & get managers on the ESXI host, or both of the before commands will show the old IP's.

Environment

VMware NSX
VMware NSX-T Data Center

Cause

In an NSX environment when you perform a restore it is expected that the same IP address will be used for the NSX managers. When this IP address changes, services that were talking to the manager via its IP can break causing situations where we see the host as disconnected. 

Resolution

Run the following command to get the controller info your ESXI host is using. In a situation where you are using fqdn instead of IP this will show the correct value, but the host might still be using a cached IP address. The second command will need to be run if the results from get managers on the ESXI host points to the old NSX manager IP. 

egrep "server|fqdn" /etc/vmware/nsx/controller-info.xml

nsxcli -c sync-aph-certificates <NSX-Manager-IP> username admin thumbprint <thumbprint>

After running both commands above run the three commands below which will flush the DNS cache and restart the services managing the nsx-controller and manager on the ESXI host, causing it to re-query for the DNS entry & IP of the NSX managers.

/etc/init.d/nscd restart
/etc/init.d/nsx-opsagent restart
/etc/init.d/nsx-proxy restart

 

Additional Information

If you have any questions regarding the host disconnects during the restore process please create a case with support. 
Uploading files to cases on the Broadcom Support Portal

Creating and managing Broadcom support cases