ESXi hosts disconnects from vCenter with error: "Disconnected from host. Reason: Agent upgrade"
search cancel

ESXi hosts disconnects from vCenter with error: "Disconnected from host. Reason: Agent upgrade"

book

Article ID: 404442

calendar_today

Updated On:

Products

VMware vSphere ESX 7.x

Issue/Introduction

Symptoms:

  • ESXi host intermittently disconnects and reconnects from vCenter.
  • In the vCenter events, we may see events similar to:

"Disconnected from host. Reason: Agent upgrade"

In the var/log/VMware/vpxd/vpxd.log on the vCenter, you may see entries similar to:

info vpxd[62202] [Originator@6876 sub=InvtHostCnx opID=HeartbeatStartHandler-122aad3] Host build number changed; [vim.HostSystem:host-XXXXX,ESXihost], old: 2458XXXX, new: 2234XXXX

info vpxd[38111] [Originator@6876 sub=vpxLro opID=lro-91629982-cc00632] [VpxLRO] -- BEGIN lro-91629982 --  -- HostDisconnectAndReconnectLRO --

info vpxd[38111] [Originator@6876 sub=MoHost opID=lro-91629982-cc00632] host [vim.HostSystem:host-XXXXX,ESXihost] connection state changed to DISCONNECTED

info vpxd[38111] [Originator@6876 sub=MoHost opID=lro-91629982-cc00632] host [vim.HostSystem:host-XXXXX,ESXihost] connection state changed to CONNECTED

 

Environment

VMware vSphere ESXi 7.x

Cause

By design when vCenter detects a build number change of the ESXi host, it triggers a ESXi host disconnect and reconnect.

Resolution

vCenter triggers a ESXi host disconnect and reconnect when ESXi host is upgraded. If this disconnect and reconnect is seen frequently then there is a possibility that another ESXi host in the environment is causing this issue.

If you encounter the symptoms mentioned in this article, Contact Broadcom support