NSX Compute Manager 'Connection Status' Down with error "Invalid credentials provided or extensions not valid"
search cancel

NSX Compute Manager 'Connection Status' Down with error "Invalid credentials provided or extensions not valid"

book

Article ID: 404209

calendar_today

Updated On:

Products

VMware NSX

Issue/Introduction

  • Compute Manager 'Connection Status' in NSX shows Down. 
  • When attempting to resolve a "Down" status on the Compute Manager in the NSX Manager UI, you may encounter the following error:
    Error: Invalid credentials provided or extensions not valid for compute manager with "ID"

Environment

VMware NSX-T Data Center
VMware NSX

Cause

This error typically indicates that the credentials stored for the Compute Manager (vCenter) are either incorrect or expired, or the required extensions/Thumbprint are not registered correctly.

Resolution

In order to resolve the issue, follow the steps below:

  1. In the NSX Manager UI, navigate to System > Fabric > Compute Managers.

  2. Locate the affected Compute Manager showing as "Down".

  3. Click "Down" under the Status column to open the error details.

  4. Click "Resolve", this will prompt you to re-enter the vCenter credentials.

  5. Enter the updated [email protected] credentials.

  6. Click "Save".

  7. The status should update and the Compute Manager should return to a "Up" state once the connection is successfully re-established.

If the issue persists, check the below:

  1. Ensure the administrator account has the required privileges in vCenter. For more information please review the administration guide Add a Compute Manager.

  2. Validate network connectivity between NSX Manager and vCenter, and check for any certificate-related warnings in Home > Alarms.

  3. Confirm all required ports are open. For more information please review VMware Ports and Protocols.

Additional Information

If you are contacting Broadcom support about this issue, please provide the following:

  • NSX Manager support bundles.
  • Text of any error messages seen in NSX GUI or command lines pertinent to the investigation.

Handling Log Bundles for offline review with Broadcom support: